Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to get a2billing to work for the past 4 days now, i followed 4 tutorials and they all gave me some insight into how things work.. but the a2billing is still not working..

my Asterisk works fine, freepbx i can make extension and place calls on trunks OK, internals perfect...

I installed a2billing.. the admin,user,agents.. all that works - i can log in add rates,trunks, the simulator get the correct routes,rates and trunks..

I can make a user log in using a sip device.. but for the love of god.. every single time i dial I get error q931_disconnect_code_21

ISDN Code says-- Cause No. 21 - call rejected. This cause indicates that the equipment sending this cause does not wish to accept this call. although it could have accepted the call because the equipment sending this cause is neither busy nor incompatible. This cause may also be generated by the network, indicating that the call was cleared due to a supplementary service constraint. The diagnostic field may contain additional information about the supplementary service and reason for rejection.

Which means the host(a2billing and asterisk) knows about the call but activbely denied routing the call.. IN the simulator i use the same number that works in there on my sip.

I am on Ubuntu 10.4LTS - Asterisk was installed using apt-get -> /usr/share/asterisk but i also have a /var/lib/asterisk

i made a ln -s to /usr/src/a2billing/AGI/a2billing.php /usr/share/asterisk/agi-bin (the asterisk conf defines this as the agi location-and freepbx time,freebpx echo works)

Another problem is that a2billing has not made 1 single log file and i cannot determine what the heck is going on(the permissions are set write global and belong to asterisk).. asterisk logs are clean.. sip, trunks are all registered.

I connect to a2billing user, place call-- silence. and just error q931(zoiper on iphone) if i use the freepbx extension i can talk with anybody iusing freepbx routes.

I followed this guide http://www.data4ict.com/tutorials/a2billing/a2billing.asp

basically i skipped freepbx out of the picture, so its just asterisk direct to a2billing.. and all the steps and verifications are just like he shows (execpt i use /usr/share/asterisk instead of /var/lib/asterisk... ??.. step by step idiot tutorial and i still cant get it working.

I set all the version to 1_6, permissions are good- i even wrote test into the a2billing_agi.log and it shows the test string on the admin end.. but never writes anything to the log file.

apache2 runs runs as www-data:www-data asterisk runs as asterisk:asterisk freepbx (i disabled it for now but runs as asterisk)

I made links to both var and usr agi-bin folder back to placed the a2billing.php with the lib link

my current config is like the ones in the turorial extensions,sips,iax'as

~# php -v PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0 PHP 5.3.2-1ubuntu4.10 with Suhosin-Patch (cli) (built: Oct 15 2011 00:09:58) Copyright (c) 1997-2009 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

asterisk -v Asterisk 1.8.8.0~rc4-1digium0+1~lucid, Copyright (C) 1999 - 2011 Digium, Inc. and others. Created by Mark Spencer Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details. This is free software, with components licensed under the GNU General Public License version 2 and other licenses; you are welcome to redistribute it under certain conditions. Type 'core show license' for details. ========================================================================= Running as group 'asterisk' Running as user 'asterisk' Unable to access the running directory (Permission denied). Changing to '/' for compatibility. Asterisk already running on /var/run/asterisk/asterisk.ctl. Use 'asterisk -r' to connect..

Asterisk 1.8.8.0~rc4-1digium0+1~lucid

A2Billing 1.9.4 (Cuprum)

Has anybody have any suggestion how to debug what is going on. Maybe if i can jsut get the logs to work that will help.. I am really bumbed out now .. 5days later.

Or is there a ready to go a2billing distro i dont know about maybe....

EDIT

So I rented a freelancer(experienced)... he sat like 4 hours, doing wierd comamnds and things...

Still not fixed.. Im just going to format and redo the while thing - It seems like i must have missed something

share|improve this question
add comment

1 Answer

You need to start debugging in Asterisk by making a call direct from Asterisk, not through A2Billing, dialling the same number and using the same caller ID. Once you have confirmed that the trunk is working correctly without the complexity of A2Billing in the way, then you can move on to sorting out A2Billing.

You may consider paid support from www.Star2Billing.com, or free support on the A2Billing forums, http://forum.asterisk2billing.org/.

share|improve this answer
    
In my post i said, using Asterisk my trunks work, i can dial using routes. I place a2billing.. remove all the exetnsions, just use the ones that route everything to a2billing.php . nothing.. no logs form a2billing.. but the sips register in asterisk--using the a2billings user! so its driving me mental.. PS I dont want to pay 600EU. –  ppumkin Dec 9 '11 at 12:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.