Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have lost "Write" permission for myself, and all other permissions for 'Others' and 'Group' on my important NTFS Partition(Contains all my Data). Any amount of Chmod(ing) or using the GUI to set it right isn't working.

I get this error when doing it the GUI way.(No other details of why it couldn't set permissions is mentioned).

enter image description here

And this happens when doing it in CLI. This is quite an issue need help fast.

enter image description here

Output of cat /etc/fstab

enter image description here

Output of dmesg | tail

enter image description here

share|improve this question
    
Please Elaborate more.. Do u mean the contents of "fstab" something like cat /etc/fstab –  Bhargav Dec 8 '11 at 12:12
    
possible duplicate of How to 'chmod' on an NTFS ( or FAT32 ) partition? –  enzotib Dec 8 '11 at 12:17
1  
As you can see, the problem is not permissions, but the 'read only file system'. Something might be wrong with the way you mounted it, or with the file system itself. Run dmesg | tail after mounting that partition to find out what's up. –  mikewhatever Dec 8 '11 at 12:21
    
@Bhargav yes, please update your question with the contents of the file, so we can see how it is mounted. –  lgarzo Dec 8 '11 at 12:25
    
@mikewhatever But it was fine until yesterday.. I don't know, I just installed a few programs yesterday, may be one of them would have changed the way it is mounted :( –  Bhargav Dec 8 '11 at 12:42

3 Answers 3

I believe your NTFS partition is mounted as read-only. This is the default behaviour when your NTFS partition is auto-mounted.
To solve this issue first identify the device file for your NTFS partition. It will be in /dev directory so the complete file name would be something like /dev/sdaX. You can find this using Disk Utility. After this create a directory in your home directory and unmount your NTFS partition using the following command:

sudo umount /dev/sdaX

now remount it using the following command to have write access to it:

sudo mount -t ntfs -o rw,auto,user /dev/sdaX /home/tintin/DIRECTORY_NAME
share|improve this answer
    
Do you want me to create a directory tintin in the home directory?? because my username is bhargav –  Bhargav Dec 8 '11 at 13:34
    
Ok here's what I did sudo mount -t ntfs -o rw,auto,user /dev/sda5 /home/bhargav/Public and even then I get this message mount: warning: /home/bhargav/Public seems to be mounted read-only. . And I'm not even able to open it :( –  Bhargav Dec 8 '11 at 13:36
    
@Bhargav Plz dont mount on /home/bhargav/Public. This is a directory used by the desktop environment so I am not sure what permissions it has and whether it can work or not. Create a new directory in your home folder for example /home/bhargav/VOLUME_LABEL and try mounting on it. –  binW Dec 8 '11 at 14:28
    
I did this sudo mount -t ntfs -o rw,auto,user /dev/sda5 /home/bhargav/volume.label as soon as its executed the folder volume.label becomes a folder that can only be accessed with Super User permissions. The drive is still not accessible and I get this error message. The folder contents could not be displayed. You do not have the permissions necessary to view the contents of "volume.label". –  Bhargav Dec 8 '11 at 17:24

I usually mount my ntfs partitions with the options:

defaults,rw,user,uid=myusername,gid=mygroupname

Of course this is assuming a single-user system. ^^

share|improve this answer
up vote 0 down vote accepted

I got my answer on ubuntuforums.org

I was using the ntfs driver and not the ntfs-3g driver. I just needed to install the ntfs-3g driver and everything worked properly.

share|improve this answer
1  
I've edited this to better reflect an answer (so that somebody looking here would know what to do) but it would be best if you could have a quick look and improve this at some point. –  Oli Feb 24 at 10:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.