Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem
I recently added ppa:eugenesan/ppa to my maverick installation to install smartgit. Right after apt-get listed a bunch of updates that I immediately installed. After rebooting I noticed that grub changed. The new version of grub is 1.99~rc1-2ubuntu1~eugenesan~maverick1. Booting up my system I had to admit that it no longer launches the login screen. It still shows the Ubuntu logo (new style also) but after that the screen turns gray.

Solution ideas
I already found the apt-get history under /var/log/apt/history.log and it lists all the software that came with the new repository. The list is huge.

Further, I read that ppa-purge can uninstall a repository and all its software. I am not sure if I understood right since it does not affect the grub version installed. That would be the easiest to see.

Can you help me to fix my system? I have access to the command line.


Vague solution steps
Thanks to Lekensteyn. In the meantime I read and tried what was written in the other thread. Nonetheless, I cannot uninstall the software version that came by eugenesan. This is what I tried:

sudo ppa-purge ppa:eugenesan/ppa
rm /etc/apt/sources.list.d/eugenesan...

Moreover, I found out that a "Previous Linux version" boots up normally. The default grub entries are Ubuntu, with Linux 2.6.35-31-generic and ..(recovery mode) - the couple that does not boot up.
But when I choose Ubuntu, with Linux 2.6.35-30-generic from the list, everything works fine. Do you understand what happens? Could it be that the graphic resolution is just set wrong OR do you think grub is the problem?

Installation log
To give a complete overview I got the history.log for apt-get. This is what happened in the meantime.

# ***** /var/log/apt/history.log *****

Start-Date: 2011-12-07  19:33:18
Commandline: apt-get install smartgit
Install: smartgit:amd64 (2.1.4-0~eugenesan~maverick9)
End-Date: 2011-12-07  19:33:36

Start-Date: 2011-12-07  19:50:00
Install:
libfile-desktopentry-perl:amd64 (0.04-2),
isc-dhcp-client:amd64 (4.1.1-P1-15ubuntu3.2~eugenesan~maverick1),
ttf-fixedsys-excelsior:amd64 (3.0-1ubuntu2~eugenesan~maverick2),
libfile-mimeinfo-perl:amd64 (0.15-1),
isc-dhcp-common:amd64 (4.1.1-P1-15ubuntu3.2~eugenesan~maverick1, automatic),
p7zip-full:amd64 (9.04~dfsg.1-1)


Upgrade:
meld:amd64 (1.3.2-1ubuntu1, 1.5.0-0ubuntu1~eugenesan~maverick1),
codeblocks:amd64 (10.05-0ubuntu1, 10.05-1~eugenesan~maverick1),
git-all:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
libglib2.0-data:amd64 (2.26.1-0ubuntu1, 2.28.0-0ubuntu1~eugenesan~maverick1),
git-daemon-run:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
network-manager-gnome:amd64 (0.8.1+git.20100809t190028.290dc70-0ubuntu3, 0.8.3+git.20110203t003354.9bf0b98-0ubuntu1~nmt1~maverick),
git-doc:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
git-cvs:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
git-gui:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
rubygems:amd64 (1.3.7-2, 1.5.3-0~eugenesan~maverick2),
libnm-util1:amd64 (0.8.1+git.20100810t184654.ab580f4-0ubuntu2, 0.8.3+git.20110201t160144.9b61ec7-0ubuntu1~nmt2~maverick),
git-man:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
screen:amd64 (4.0.3-14ubuntu4, 4.1.0git066b098-0~eugenesan~maverick3),
libpcre3:amd64 (8.02-1, 8.12-1~eugenesan~maverick1),
hotot:amd64 (0.9.7~git-1259-g63e05cf-0ubuntu0ppa1~maverick1, 0.9.7~git-1280-g9b00609-0ubuntu0ppa1~maverick1),
git-svn:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
libsoup-gnome2.4-1:amd64 (2.31.92-0ubuntu1.1, 2.32.2-2ub~eugenesan~maverick1),
grub-pc:amd64 (1.98+20100804-5ubuntu3.3, 1.99~rc1-2ubuntu1~eugenesan~maverick1),
libglib2.0-0:amd64 (2.26.1-0ubuntu1, 2.28.0-0ubuntu1~eugenesan~maverick1),
git-email:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
network-manager:amd64 (0.8.1+git.20100810t184654.ab580f4-0ubuntu2, 0.8.3+git.20110201t160144.9b61ec7-0ubuntu1~nmt2~maverick),
gitweb:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
git:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
libnm-glib2:amd64 (0.8.1+git.20100810t184654.ab580f4-0ubuntu2, 0.8.3+git.20110201t160144.9b61ec7-0ubuntu1~nmt2~maverick),
codeblocks-common:amd64 (10.05-0ubuntu1, 10.05-1~eugenesan~maverick1),
rdesktop:amd64 (1.6.0-3ubuntu2.1, 1.7.0-1ubuntu2~eugenesan~maverick1),
libglib2.0-bin:amd64 (2.26.1-0ubuntu1, 2.28.0-0ubuntu1~eugenesan~maverick1),
git-el:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
libglib2.0-dev:amd64 (2.26.1-0ubuntu1, 2.28.0-0ubuntu1~eugenesan~maverick1),
xdg-utils:amd64 (1.0.2+cvs20100307-1ubuntu0.3, 1.1.0~rc1-2~eugenesan~maverick1),
initramfs-tools:amd64 (0.98.1ubuntu6.1, 0.99ubuntu2.1~eugenesan~maverick1),
y-ppa-manager:amd64 (0.0.8.4-1~webupd8~maverick3, 0.0.8.5-1~webupd8~maverick),
codeblocks-contrib:amd64 (10.05-0ubuntu1, 10.05-1~eugenesan~maverick1),
git-arch:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
gitk:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
dhcp3-client:amd64 (3.1.3-2ubuntu6.3, 4.1.1-P1-15ubuntu3.2~eugenesan~maverick1),
libcodeblocks0:amd64 (10.05-0ubuntu1, 10.05-1~eugenesan~maverick1),
rubygems1.8:amd64 (1.3.7-2, 1.5.3-0~eugenesan~maverick2),
python-support:amd64 (1.0.9ubuntu1, 1.0.10ubuntu3~eugenesan~maverick1),
git-core:amd64 (1.7.7.2-1~ppa0~maverick1, 1.7.8-0ppa1~maverick1),
ttf-mscorefonts-installer:amd64 (3.2ubuntu2, 3.3ubuntu4~eugenesan~maverick4),
shutter:amd64 (0.88~ppa4~maverick1, 0.88.1~ppa3~maverick1),
handbrake-gtk:amd64 (4370svnppa1~maverick1, 4373svnppa1~maverick1),
python-gdata:amd64 (2.0.8-1.1, 2.0.13-1~eugenesan~maverick1),
grub-common:amd64 (1.98+20100804-5ubuntu3.3, 1.99~rc1-2ubuntu1~eugenesan~maverick1),
libjson-glib-1.0-0:amd64 (0.10.2-2ubuntu2.1, 0.12.2-0ubuntu1~eugenesan~maverick1),
libwxsmithlib0:amd64 (10.05-0ubuntu1, 10.05-1~eugenesan~maverick1),
ppa-purge:amd64 (0.2.8+bzr56~webupd8~maverick, 0.2.8+bzr59-0~61~maverick1),
initramfs-tools-bin:amd64 (0.98.1ubuntu6.1, 0.99ubuntu2.1~eugenesan~maverick1),
dhcp3-common:amd64 (3.1.3-2ubuntu6.3, 4.1.1-P1-15ubuntu3.2~eugenesan~maverick1),
libsoup2.4-1:amd64 (2.31.92-0ubuntu1.1, 2.32.2-2ub~eugenesan~maverick1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)    
End-Date: 2011-12-07  20:03:24

Start-Date: 2011-12-08  11:31:33
Commandline: apt-get remove
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2011-12-08  11:31:35

Start-Date: 2011-12-08  11:37:57
Commandline: apt-get install ppa-purge
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2011-12-08  11:37:58

Start-Date: 2011-12-08  11:38:59
Commandline: apt-get remove rubygems1.8
Remove: rubygems:amd64 (1.5.3-0~eugenesan~maverick2), rubygems1.8:amd64 (1.5.3-0~eugenesan~maverick2)
End-Date: 2011-12-08  11:39:08

Start-Date: 2011-12-08  12:01:08
Commandline: apt-get purge screen
Purge: ubuntu-desktop:amd64 (1.207), byobu:amd64 (3.5-0ubuntu1.1), ubuntu-netbook:amd64 (2.035), screen:amd64 (4.1.0git066b098-0~eugenesan~maverick3)
End-Date: 2011-12-08  12:01:20

All entries from Start-Date: 2011-12-08 11:31:33 and later are already me trying to fix the system. There seems to be an error in the initial "eugenesan-installation"


Kernel under suspicion
Could it be that kernel 2.6.35-31 is not working on my machine? I cannot see an installation had happened in the history.log, though. In case I want to remove the kernel I found an article on how to remove a grub menu entry.

share|improve this question
    
possible duplicate of How can PPAs be removed? –  Lekensteyn Dec 8 '11 at 11:40
    
unfortunate title which would have meant this is a dup - however give the latest info - probably a genuine problem. I've changed the title to reflect the actual question asked. –  fossfreedom Dec 8 '11 at 21:58
add comment

1 Answer

up vote 1 down vote accepted

I removed the kernel 2.6.35-31 as already mentioned. I am totally unsure about what happened. But in the meantime I can use my system again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.