Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

When I start up Ubuntu (11.10), no graphical interface loads. This is the case both in normal and recovery mode. Instead I'm being presented with a console, logged as 'root@ubuntu'. From there I can call exit and then log into my default (and only) account, and once there I can load the unity with the command startx but to get to unity I have to repeat above everytime I start up the PC.

I hope some of the details below might be able to indicate what's exactly the problem. I tried several solutions I found on the web, but to no avail.

My graphics card: Nvidia GeForceGT 540M

Result of typing in console:

WARNING: no DISPLAY variable set, setting it to :0
    unity-panel-service: no process found
    compiz (core) - Fatal: Couldn't open display :0

Result of typing


ERROR: The control display is undefined; please run 'nvidia-settings --help' for usage information.

Content of default xorg.conf:

Section "Device"
    Identifier    "Default Device"
    Option    "NoLogo"    "True"

Content of xorg.conf created with nvidia-xconfig

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 280.13  (  Wed Jul 27 17:15:58 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

The problem occurs with both xorg.conf versions. I tried installing, purging, reinstalling nvidia drivers, editing blacklist as per NVIDIA drivers not working after upgrade. Why can I only see terminal? all to no avail. I would greatly appreciate any pointers that would help me resolve the issue.

The reason I tried messing with nvidia drivers in the first place is that some gtk/OpenGL stuff didn't work correctly. In particular, the Xorg.0.log contains the following error:

(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Well, fixing the lack of any desktop whatsoever is the priority, but should you happen to know how I might be able to resolve the GLX extension problem, I would be happy to keen to hear you out.

share|improve this question
possible duplicate of How well do laptops with Nvidia Optimus work? –  Lekensteyn Dec 8 '11 at 11:40
@Lekensteyn - well, yes and no. Methods listed there didn't sort out my desktop, must be I messed it up in yet some other ways I haven't reported, but they made it clear how to proceed from a clean install. Thank you for the link. –  Puchatek Dec 9 '11 at 13:22

2 Answers 2

You could try running lspci in a terminal, if you see:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation      Core Processor Family Integrated Graphics Controller (rev 09)

you will need to install bumblebee (the instructions on the git wiki are quite clear). It's needed to switch between the intel and nvidia optimus card.

The correct xorg.conf is the first one, and remove nvidia driver from the blacklist.

share|improve this answer

I've found that if you rm or mv xorg.conf file (at /etc/X11/xorg.conf), then at least it'll boot up into GUI. I can't get my video card to work at all either, but at least it'll boot up using the built-in vga video card

Ubuntu 11.10 Video card: nvidia geforce fx 5200

I have the same error in my xorg.0.log file

Good luck!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.