Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm trying to use Thunderbird again, but I can't make it use Firefox to open links. I'm using KDE and Firefox is my default browser. I tried the network.protocol-handler method but it doesn't work.

share|improve this question

marked as duplicate by gertvdijk, Radu Rădeanu, Eric Carvalho, Kevin Bowen, guntbert Sep 5 '13 at 14:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
There look at the second answer (not the accepted one). –  guntbert Sep 5 '13 at 14:36

2 Answers 2

up vote 0 down vote accepted

To open links in thunderbird so that they will open firefox or chrome or opera, you open preferences, attachments, and click on use other and navigate to the browser that you want to use.

share|improve this answer
    
I have already tried that, but there is nothing to select. goo.gl/KafD –  lovinglinux Oct 21 '10 at 14:21
    
I'm accepting this answer, but I decided to use Opera for mail, instead of Thunderbird, so will no longer testing other options. –  lovinglinux Oct 23 '10 at 0:47

It seems that thunderbird uses sensible-browser, that actually tests for the following alternatives: gnome-www-browser and x-www-browser; so what you need to do is manage your altenatives with:

sudo update-alternatives --config gnome-www-browser
sudo update-alternatives --config x-www-browser

And the choose Firefox for those.

Probably you'd only need to update x-www-browser since you're using KDE.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.