Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a secondary monitor connected to my laptop's VGA output.

However, many app popup dialogs, including Ubuntu's display settings show up on that secondary monitor. This is very annoying because I use it for display and I cannot easily see that monitor when working.

I have Unity menus on the laptop, which is supposed to be my primary. How can I enforce all new windows and monitor settings also show up on primary monitor?

I edited monitors.xml and added primary = yes to all displays which looked like laptop screens (for some reason I have several configurations there). Logged out and back in - same problem. See monitors.xml at http://pastebin.com/zJgstAbf

share|improve this question
    
I'm not sure of a fix for this problem, but changing the RandR config in monitors.xml is unlikely to help. In my experience, Compiz (the window manager Unity 3D is based on) doesn't do as good a job at placing new windows in multi-head environments as Metacity did. Since Unity-2D is based on Metacity though, you could try picking it at login as a workaround. –  James Henstridge Dec 8 '11 at 7:59
    
I see, I did not realize I was using 3D since my graphics card is very basic on this laptop. Looks like I have it running in software mode. Will try to switch to 2D and see if it helps, thanks! –  alexandroid Dec 9 '11 at 6:32
    
It worked, thank you @JamesHenstridge! –  alexandroid Dec 9 '11 at 6:43
add comment

1 Answer

Looks like switching to Unity 2D helped - now display settings show up on primary monitor.

Wow, this also made my desktop fast again, I did not realize how much slower Unity 3D was until this switch back! Thank you, James!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.