Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Windows partition which I can easily access using Nautilus.

It automatically gets mounted at /media

deel@ubuntu:/media$ ls -l
total 16
drwx------ 1 deel deel 16384 2011-11-16 10:33 New Volume  

deel@ubuntu:/media$ sudo chmod 755 New\ Volume/  

deel@ubuntu:/media$ ls -l  

total 16
drwx------ 1 deel deel 16384 2011-11-16 10:33 New Volume

If you notice in above even after changing permissions the permissions have not changed. What could be the reason and how can I change the permissions?

Here is my /etc/fstab file:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/host/ubuntu/disks/root.disk /               ext4    loop,errors=remount-ro 0       1
/host/ubuntu/disks/swap.disk none            swap    loop,sw         0       0
~                                                                                      
share|improve this question

1 Answer 1

up vote 0 down vote accepted

The permissions for a windows share are determined at mount time, and cannot changed at run time.

If you want different permissions, you have to manually mount the partition and provide options to the command to give all files and directories the required permissions.

Also, you can set the permissions in /etc/fstab, that in addition to the noauto option should allow to mount with nautilus with option determined in fstab.

The command could be

sudo mkdir -p "/media/New Volume"
sudo mount -o uid=1000,gid=1000,umask=0022 /dev/sd1 "/media/New Volume"

where 0022 is the complement to 755 = rwxr-xr-x, /dev/sda1 is the windows partition, and 1000 is your numeric user id and group id.

share|improve this answer
    
Here is my /etc/fstab file # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc nodev,noexec,nosuid 0 0 /host/ubuntu/disks/root.disk / ext4 loop,errors=remount-ro 0 1 /host/ubuntu/disks/swap.disk none swap loop,sw 0 0 ~ –  Registered User Dec 12 '11 at 5:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.