Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Qt Creator from the Ubuntu Software Center.

When I try to open any project other than a Qt Quick project I get following error message:

No valid qt versions found.
Please add a qt version in Tools/Options or via the maintenance tool of the SDK.

In Tools → Options → Qt4, qmake-qt4 was added to the list automatically.

This is what my Qt4 options menu looks like.

qt-creator options menu

Here is the output of dpkg --get-selection | grep qt.

What am I missing to get Qt Creator to let me open Qt C++ projects?

share|improve this question
    
Add the name of the packages that you have installed check if you have qt-maker, designer, creator. –  Bruno Pereira Dec 7 '11 at 19:15
    
I have designer, qtcreator and qmake-qt4. –  Octavian Damiean Dec 7 '11 at 19:21
    
Please provide the output of dpkg --get-selections | grep qt. –  Andrejs Cainikovs Dec 7 '11 at 20:26
    
You should also check for libqt4-dev. –  Nathan Osman Dec 7 '11 at 20:41
    
@AndrejsCainikovs Added the requested information to my question. –  Octavian Damiean Dec 7 '11 at 21:00
add comment

3 Answers

up vote 4 down vote accepted

The problem wasn't the missing Qt version but the missing tool chain.

In Tools → Options → Tool Chains add GCC and set your gcc path as the Compiler path.

share|improve this answer
add comment

I thought the qtCreator package would install g++, make, etc., but it doesn't. Install build-essential to solve it :).

share|improve this answer
add comment

As to me, it looks perfectly fine. My Qt versions tab in options dialog looks identically.
The only thing that comes into my mind, is that Qt version is saved per-project, which means that you need to change Build Settings in Projects tab by explicitly selecting Default Qt Version.

share|improve this answer
    
Don't judge hard, I might be wrong :) –  Andrejs Cainikovs Dec 7 '11 at 21:16
    
Thanks for your help. I've posted an answer with the solution. –  Octavian Damiean Dec 7 '11 at 21:56
    
Hmm.. Why the hell you don't have gcc in your PATH? :) –  Andrejs Cainikovs Dec 8 '11 at 12:35
    
Well I don't know why it couldn't find it since /usr/bin is definitely in my PATH and gcc is in there. –  Octavian Damiean Dec 8 '11 at 13:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.