Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I just installed 11.10 on my Dell Precision T5500 from the live cd. The live cd worked fine, but when I attempt to boot from hard drive I end up at the BusyBox prompt. However, if I simply type "exit" and Enter it continues booting and I get the Ubuntu graphical login screen. How do I fix things so I don't stop at the BusyBox prompt?

I found an interesting similar problem at http://samiux.wordpress.com/2008/12/16/howto-avoid-to-drop-to-busybox-in-ubuntu-810/, but can't exactly implement the solution since the /boot/grub/menu.lst file doesn't appear to exist in 11.10.

Any ideas? It would be nice to be able to reboot my system remotely.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You can try the solution you found by editing /etc/default/grub instead; edit the line labelled GRUB_CMDLINE_LINUX_DEFAULT and run sudo update-grub to make the changes take effect.

You should end up with something like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash bootdelay=90"

This has the same effect as editing menu.lst (actually, it's now called grub.cfg) but in a way that the Ubuntu packages understand, so when a kernel or grub gets updated, the changes will persist. You generally don't want to be editing the grub config manually.

share|improve this answer
1  
It works! But the option I had to use was "rootdelay", not "bootdelay" as in the blog I came across. Thank you, Caesium! –  Clark Dec 7 '11 at 18:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.