Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I insert something in my phone output jack, the sound is muted and I have to go into alsamixer and turn up the volume on the Speaker lever.

I can see the reason this is so - when I'm listening in phones, I don't want the laptop speakers on - but my hardware does this for me automatically, and the Speaker lever goes to the phone jack when something is inserted there. The result of alsamixer doing this adjustment is that I have to open a terminal, type alsamixer, find the speaker lever and turn it up again, every time I insert something in the phone jack.

There has to be a way to turn off this behavior. But how?

share|improve this question

3 Answers 3

Which sound card do you have? A bug was reported recently.

Potential solutions/workarounds:

In your sound settings, try switching to analog speakers. It should look something like this:

Analog

Your other option would be to try the updated packages from the alsa daily snapshots:

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get upgrade

You will likely need to log out and back in, or perhaps reboot.

share|improve this answer
    
I was already on analog output (in fact, analog duplex). Switching to digital did not help, neither did switching back to analog... –  Tomas Lycken Dec 14 '11 at 13:09
    
And running the commands to upgrade alsamixer, no update was found. –  Tomas Lycken Dec 14 '11 at 13:12
    
What sound card do you have ? –  bodhi.zazen Dec 14 '11 at 15:53
    
Quite honestly, I don't know exactly how to find that out in Ubuntu. I'm quite new at this. I tried sudo lshw but it didn't give me anything. Where do I check? –  Tomas Lycken Dec 14 '11 at 20:06
    
can you run ` sudo lshw -c multimedia -sanitize | pastebinit` you may need to install pastebinit help.ubuntu.com/community/Pastebinit . Post the url back here –  bodhi.zazen Dec 14 '11 at 21:11

I found a way to do this!

  1. Start alsamixer:

    $ alsamixer
    
  2. Hit F5 to show all devices.

  3. Scroll to the right until you find Auto-Mute Mode. Set it to disabled.

Done! My sound no longer mutes whenever I insert a plug in the phone jack!

share|improve this answer
    
Great, thanks for posting the solution. –  bodhi.zazen Jan 10 '12 at 23:36
    
It is possible that the package containing alsamixer has been updated since I first had this problem, if an update was published at the same time as many other updates - I usually don't read through the list too carefully if it's long :P This works with the version currently in the software repository for Ubuntu 11.10, though, so that shouldn't pose a problem for people finding this question in the future. –  Tomas Lycken Jan 11 '12 at 12:10
1  
Turns out this wasn't so successful anyway: when I do this, the speakers on my laptop aren't muted at all. So now I can plug in something in my phone jack without having to go to alsamixer and turn the volume back up, but instead I have sound from both phones and speaker... =( –  Tomas Lycken Jan 14 '12 at 15:50
up vote 0 down vote accepted

This problem seems to be resovled out of the box in Ubuntu 12.04, without any (concious) action on my part. I guess that's a yay! =)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.