Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Ubuntu PC is behind a proxy server that requires a password. On Windows it automatically uses windows authentication (e.g. with Internet Explorer), or enter it manually (e.g. Avast). I did a search but could not find a similar question to address this issue.

I'm already aware of the global network proxy preferences (System > Preferences > Network Proxy), but it only takes the proxy server and port. This is not a problem with Firefox, because it prompts for the username and password. How do I make this work for Ubuntu's Software Center? It only prompts me for my user password, but the Ubuntu user is not a network user.

Error Detail: W:Failed to fetch http://extras.ubuntu.com/ubuntu/dists/maverick/main/source/Sources.gz 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )

I'm using Ubuntu 10.10, and my Linux skills are somewhat rusty.

EDIT: ddk's answer seems like what I'm looking for, but I cannot seem to get cntlm to work correctly. I followed the configuration steps he provided, and I updated to global network proxy to localhost:<listen_port> and removed my username and password (under detail). The test command sudo cntlm -M http://google.com/ passed, but when I test it with Firefox cntlm fails with the error "502 Parent proxy unreachable."

EDIT FIXED: It worked after I rebooted. The restart command invoke-rc.d cntlm restart does not restart, so the config file is never read.

share|improve this question
1  
global network proxy also takes the username and password just click on details –  Engels Peralta Dec 7 '11 at 16:03
    
Thanks Engels, but that still did not fix it. Maybe there's another problem. –  Peet Brits Dec 8 '11 at 7:30
add comment

2 Answers 2

up vote 2 down vote accepted

You can use cntlm to manage ISA proxy settings.

To get around the catch 22 of installing it, without Ubuntu Software Center being able to connect to the internet, open synaptic, choose to install cntlm and go to File->Generate package download script. Open the script in a text editor and download and install the package manually.

There is a very thorough guide to configure cntlm here.

share|improve this answer
    
cntlm is not in Synaptic's list. –  Peet Brits Dec 8 '11 at 7:59
    
Ignore my previous comment. I'll download it from sourceforge. –  Peet Brits Dec 8 '11 at 8:11
    
The cntlm commandline test passed, but firefox gives "502 Parent proxy unreachable." Any ideas? –  Peet Brits Dec 8 '11 at 9:47
    
I resolved it. See my post. –  Peet Brits Dec 8 '11 at 12:22
    
getting error sudo cntlm -M google.com Config profile 1/4... Auth not required (HTTP code: 301) Config profile 2/4... Auth not required (HTTP code: 301) Config profile 3/4... Auth not required (HTTP code: 301) Config profile 4/4... Auth not required (HTTP code: 301) Your proxy is open, you don't need another proxy. –  Deepak Rajput Dec 8 '11 at 12:47
add comment

I also had the same problem but i applied the proxy system wide through network option which you will find in Dash home.

Sometime i need to refresh the Firefox also, this is the problem with Isa we need to adjust.

But INTERNET work fine Firefox and Ubuntu software center, See that you have the download permission of DEB extension

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.