Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop Thinkpad Edge e320 got out of standby with bluetooth and wireless disabled. WiFi got enabled normally in unity but bluetooth says that "bluetooth is disabled by hardware switch".

There is no hw switch on my laptop. I tried:

# echo 1 > /sys/devices/platform/thinkpad_acpi/bluetooth_enable 
bash: echo: write error: Operation not permitted

but as you see no results.

Fn-F9, which is radio control, does not work. Any help?

share|improve this question
    
Do you have root account enabled ? –  funkymonk Dec 7 '11 at 10:43
    
yes, '#' indicates that it is executed as root –  Robert Mutke Dec 7 '11 at 16:46
    
Do you still have this problem? –  Braiam Nov 18 '13 at 23:28
    
Yes, I've got it –  Robert Mutke Nov 19 '13 at 6:41
add comment

2 Answers 2

Maybe a bios setting is keeping the radio off?

If you haven't been in the bios setup menu before, there is usually an fn key you press when your manufacturer logo shows at boot.

share|improve this answer
1  
Nope, there is nothing in bios. What I do, I boot to Win7, press Fn-F9, which is radio control, and enable bluetooth there. After that I can boot back to Linux and it is enabled. So it is disabled in HW but for some reason Linux cannot handle it. –  Robert Mutke Dec 19 '11 at 8:09
add comment

I have the same issue on Lenovo ThinkPad Edge E320, and I resolved it by reseting BIOS settings. Be careful if you use EFI boot - it will erased and you will need to recover it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.