Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Each time I do a computer restart the GNOME Shell theme I have enabled before the restart gets reset to the 'default' theme when I log in after a restart. The default theme is the black panel. Is it possible to set the theme to stick to my custom theme?

share|improve this question
    
What method are you using to set the theme? –  Barbarrosa Dec 7 '11 at 4:27
add comment

2 Answers 2

I simply followed the instructions given on this site:

http://www.techdrivein.com/2011/10/how-to-install-and-manage-gnome-shell.html

Simply put:

  1. Install gnome-tweak-tool (e.g., sudo apt-get install gnome-tweak-tool in the Terminal)
  2. Unzip a theme into the ~/.themes directory, e.g. ~/.themes/Faience/
  3. Open gnome-tweak-tool (appears in the menu as "Advanced Settings")
  4. Open the "Shell Extensions" section and set "User Themes Extension" to "ON"
  5. Open the "Theme" section and select "Faience" (my theme) in the "Shell theme" dropdown list

I rebooted, and my theme remained the same.

share|improve this answer
    
That's how I set my theme. I installed gnome shell from the software center. Rebooted into GNOME, downloaded themes from this ppa: webupd8.org/2011/12/satyas-gnome-shell-gtk-themes-ppa.html, I installed gnome tweak tool, I also installed MSGE's. When I reboot the theme gets reset to default, but when I open up the tweak tool, the theme is not default but the custom theme so I have to select a different theme and then set the custom theme again. –  mac1133 Dec 7 '11 at 13:48
1  
Did you install the User Themes extension from the official GNOME Extensions website? If so, remove it (should be under ~/.local/share/gnome-shell/extensions/) and only use the one in the WebUpd8 GNOME 3 PPA. Let me know if it works... –  Alin Andrei Dec 7 '11 at 19:20
add comment

I had the same problem. When I rebooted or do Ctrl+F2 r it would reset to the default shell theme. I have installed it with the webupd8 ppa.

I look with my nose :P. I had the extension two times; I disabled one and it works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.