Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I enable the thesaurus in LibreOffice?

share|improve this question
1  
Have you done this?: sudo apt-get install openoffice.org-thesaurus-en-us (English Thesaurus for LibreOffice/OpenOffice.org) –  david6 Dec 7 '11 at 0:33
add comment

9 Answers

The same problem goes for the Australian dictionary. I went into Synaptic, and installed mythes-en-au : then I was able to use it without a problem.

share|improve this answer
add comment

Using the standard installation of LibreOffice you don't have to install it. It is already installed. You can right click any word choosing the entry »Synonyms«. Now you will get a list of synonyms to the selected word. If this does not work

  • go to then main menu »Tool->Options«,
  • choose the sub menu (on the left column) »Language Settings->Writing Aids«
  • and then enable the option »OpenOffice.org new thesaurus« under the category »Writing Aids«.

That's it.

If this option is marked, but the thesaurus option in the tools>language menu is still grayed, then you have to perform this command using terminal:

sudo apt-get install openoffice.org-thesaurus-en-us
share|improve this answer
1  
I have performed that command using the terminal, a package was installed,i shut down the pc and restarted it, opened LibreOffice and the thesaurus is still grayed. –  user48583 Feb 29 '12 at 13:18
add comment

Initially, the thesaurus uses the language of the selected word in the document, if a thesaurus library for that language is installed. The title bar of the Thesaurus dialog displays the language in use.

You can install languages with a thesaurus library from the Extensions web page.

References and more info can be found on the LibreOffice site here.

share|improve this answer
add comment

I fixed this problem by installing Thesaurus:

sudo apt-get install openoffice.org-thesaurus-en-us

Then selecting all the text and changing to USA:

ToolsLanguageFor All Text → select English (USA)

I can now access:

right-click → Synonyms

share|improve this answer
add comment

Click on Tools -> Language -> For All Text -> Select English (USA).

share|improve this answer
2  
Is this different from this much older and more detailed answer? –  Eliah Kagan Jul 15 '12 at 17:07
    
No. I'm sorry, I didn't see it. –  Akshit Baunthiyal Jul 15 '12 at 18:13
    
Well, this answer does explain how to select English (USA). So you may want to keep it. Or you could suggest an edit to that answer, and if/when it's approved, you could delete this answer. It's your call. –  Eliah Kagan Jul 15 '12 at 18:23
    
I'll just let it be. I've upvoted the other answer. –  Akshit Baunthiyal Jul 15 '12 at 18:47
add comment

It isn't that LibreOffice doesn't have the Thesaurus. It does, but for some reason it wasn't turned on when I installed mine.

Go to Tools > Options > Language Settings > Writing Aids > Options, make sure the top two items are checked: Check spelling as you type and Check grammar as you type.

After doing that I had the Thesaurus. I also had Check spelling as you type, but you can disable that in the toolbar, by clicking the ABC with the red squiggly line under it.

To use the Thesaurus, Ctrl+F7, or right-click on the word for which you want a synonym, hover over Synonyms.

share|improve this answer
add comment

Using LO 3.5.3.2 on Ubuntu 10.04 the following got me going:

(1) Tools > Options > Language Settings > +Languages: set 'default languages for documents to 'English (UK)' or 'English (USA)' (you'll notice that these two have spelling symbols next to them - not sure if this only relates to dictionaries or to thesauri as well.

(2) Tools > Options > Language Settings > +Writing Aids: edit 'Available language modules' > 'OpenOffice.org New Thesaurus' and choose 'Language' to be English (UK) or (USA) as desired.

I also downloaded and installed the thesaurus created by the weekly whinge at the same time, but perhaps you might not need to do that. At any rate, even after installing the whinger's extension I still only see 'OpenOffice.org New Thesaurus' in the writing aids dialogue.

You should also probably make sure all of your text in your document is set to the same language as chosen in steps above.

share|improve this answer
add comment

Trust me, it works.

Download and install this Libreoffice extension:

American British Canadian - spelling/hyphen/thesaurus dictionaries Libreoffice extension

American English - hyphenation, thesaurus, 638K+ word list extension worked for me. Just start Libreoffice and the thesaurus won't be grayed i.e. you can use Ctrl+F7 to open thesaurus dialog.

share|improve this answer
1  
I installed it and nothing happens –  Muhammad Ahmad Zafar Mar 8 '13 at 6:56
add comment

It is strange but, if you use English (UK) for your paragraph, Libreoffice does NOT use thesaurus. You check this under Tool > Options > Language Settings > Writing Aids > Modify and see that English (UK) has no thesaurus.

If you choose the English (USA) you can use the thesaurus. I think the problem is solved in this way.

share|improve this answer
2  
You can get the thesaurus working now with UK English, I posted a how-to here. –  Tom Brossman Oct 3 '12 at 20:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.