Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to remove the MeMenu, without removing the logout/shutdown/restart/etc. button next to it. I never use social networks, so I have no use for this function. Any tips?

share|improve this question
    
You can remove it from panel without completely removing it from the system –  user Apr 18 '11 at 6:13
add comment

3 Answers

up vote 5 down vote accepted

Try:

sudo apt-get remove indicator-me

If you also want to get rid of the Messaging Applet:

sudo apt-get remove indicator-me indicator-messages

share|improve this answer
1  
There's no need to remove indicator-messages for this purpose. That will remove the messaging indicator as well. –  mgunes Oct 20 '10 at 22:55
    
Oh, I don't want that! Anything else? –  Lyrositor Oct 20 '10 at 23:00
    
Wait, that worked! It completely removed it! Perfect. I just removed that last part about indicator-messages. –  Lyrositor Oct 21 '10 at 1:05
    
Thanks for clarifying that. –  Lifer999 Oct 21 '10 at 3:56
add comment

To only display the session manager, launch gconf-editor from the terminal or the "Run Application" dialog (call by pressing Alt+F2). Next browse to /system/indicator/me/ and change the vaulue for display from 1 to 0.

gconf

Or you can just run this command in the terminal:

gconftool -s /system/indicator/me/display --type int 0

To re-enable the MeMeun, run:

gconftool -s /system/indicator/me/display --type int 1

share|improve this answer
    
Perfect, worked like a charm. Thanks a ton! –  Lyrositor Oct 20 '10 at 23:21
1  
Oh, wait, just one thing. Not really important, but the icon is still there. The username is gone though, which is the most important. –  Lyrositor Oct 21 '10 at 0:36
    
As @Lyristor said this doesn't quite do as requested! –  fluteflute Oct 21 '10 at 7:19
    
Hmmm.... Are you on Lucid? It works for me on Maverick. Watch: people.ubuntu.com/~andrewsomething/misc/memenu.ogv –  andrewsomething Oct 21 '10 at 13:04
    
Reboot. You'll see what happens. –  Lyrositor Oct 21 '10 at 19:54
add comment

You can also add applications you don't want to appear in the dropdown to the blacklist at ~/.config/indicators/messages/applications-blacklist by copying their configuration from /usr/share/indicators/messages/applications into that directory. See this bug for more discussion.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.