Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my laptop (Lenovo Ideapad v570), which came with 750GB HDD with 4 NTFS primary partitions I installed ubuntu by following these steps

The 4 partions were, 1.(650GB)Windows7 2. (30GB) Lenovo/Drivers 3.System 210 MB 4. (16GB)Recovery

  1. I shrunk the windows drive to 245GB, by using disk management in windows 7 and created unallocated free space of ~450GB
  2. Using ubuntu live cd , I installed ubuntu 11.10 by selecting the option Ïnstall along side windows
  3. Ubuntu 11.10 was installed without any error.

    But on reboot, the boot menu does not appear and system boots into Windows 7 . I checked again using ubuntu live cd, and ubuntu is actually installed on the harddrive. (I could browse the files)

    The ubuntu disk utility output is as shown below. The ubuntu disk utility output

As can be seen in the screenshot, there is a warning that says, "Partition is misaligned by 1024 bytes. This may result in very poor performance. Repartitioning is suggested". Does this warning has anything to do with the problem?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I have encountered the misaligned partition warning before and it never effected the system booting. More than likely the reason your system is booting straight into Windows 7 and not prompting you is because Ubuntu wasn't added to the MBR. If you are comfortable editing your MBR then log into Windows and do so. If you are not that comfortable doing so, I would suggest a program called EasyBCD. EasyBCD is a program that gives you a GUI to edit your MBR, and it is incredibly easy to use.

Here is a link to EasyBCD: http://download.cnet.com/EasyBCD/3000-2094_4-10556865.html?tag=mncol;1

share|improve this answer

I had the same problem. First i used supergrup cd to start ubuntu. when you´re in ubuntu you can download the programm boot-repair. Now you have to use the advanced settings, i tested different ways to change the mbr. Do not change any setting, just run boot-repair under advanced setting.

It worked. Good luck.

share|improve this answer
    
+1, installed ubuntu again , after formating the partitions and it worked well. I think Ubuntu wasnt added to MBR for some reason –  AIB Dec 14 '11 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.