Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new router (Speedport W 921V) which has USB ports on which I connected my printer (HP DeskJet 950C).

Printing works (URI: lpd://192.168.2.1/lpt1), but after each job, the printer sucks out one extra blank page.

How can avoid this extra non printed page?

(I'm using Xubuntu 11.10 and hplip 3.11.7-1ubuntu3. If the printer is connected to the PC directly or via a Windows computer (samba), the problem doesn't occur.)

share|improve this question

closed as too localized by Stephen Myall, qbi, Eric Carvalho, Uri Herrera, Seth Feb 26 '13 at 1:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Xubuntu 11.10 and hplip 3.11.7-1ubuntu3. According to wiki.linuxfoundation.org/en/OpenPrinting/Database/… , I also tried to set ps_accounting = 0 in /etc/foomatic/filter.conf, no effect. (/usr/lib/cups/filter/cupsomatic is not a readable file) –  Bazon Dec 8 '11 at 15:12
    
IPP instead of LDP doesn't work at all. –  Bazon Dec 9 '11 at 14:01
    
lpd://192.168.2.1/LPT1_PASSTHRU: same as before, job ends with one blank page lpd://192.168.2.1/PASSTHRU: doesn't print, error message: /usr/lib/cups/backend/lpd failed –  Bazon Dec 9 '11 at 15:41
    
when setting up the 950c you have a choice of 6 drivers - does any of the others (i.e. not the recommended driver) work better? –  fossfreedom Dec 10 '11 at 23:04
1  
This question appears to be abandoned and unanswered, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. –  Aditya Feb 25 '13 at 19:03

1 Answer 1

Try adding this option at the bottom of /etc/printcap

:sf:\
share|improve this answer
    
No effect. (I did that and restarted cups afterwards with sudo /etc/init.d/cups restart ) –  Bazon Dec 9 '11 at 14:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.