Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have read several questions relating to getting WINE to recognise the CD-ROM drive with no success. I have installed a Windows game and when I go to play it, I get a "Please insert disk into CD-ROM drive" message.

I have tried telling WINE to designate the CD-ROM drive D:, tried editing FSTAB to mount the drive on startup, and attempted to find the UUID to see if that makes things easier but cannot find it.

Is there a way to assign a static mount point for the CD/DVD-ROM drive so WINE can address it instead of the random (/media/"disk name")

share|improve this question
2  
I believe you need to give wine the block device ( /dev/cdrom ), not the mounted filesystem. –  psusi Dec 6 '11 at 15:00
    
@psusi - Played with the settings and put /dev/cdrom as D: but still will not work :( –  Andrew Dec 7 '11 at 13:06

1 Answer 1

I don't know how to make it static, but on the first time after reboot, you can just start

winecfg

And use the auto-detect feature for assigning a windows drive letter to the mounted dvd/cdrom drive.

After that, autodetect would only re-map to the (first) mounting - no idea why. For the non-first mountings use winecfg as well and re-assign the drive-letter manually after the drive has been mounted.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.