Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed VirtualBox from the Software Center on 64-bit Ubuntu 11.10. When I try to install a 64-bit Windows 7 guest I get the following error:

Attempting to load 64 bit however this CPU is not compatible with 64 bit mode.

enter image description here

My host is Ubuntu 64-bit, how is it not compatible?

share|improve this question
2  
You probably need to enable it in BIOS, like @Achu's answer below. If you need help doing that post a reply to this comment. We need to know what kind of computer it is to see how you access the BIOS settings. –  Tom Brossman Dec 6 '11 at 11:37
    
I have the same problem and wouldn't know where to get started with enabling virtualisation in my bios. I have a Asus P5QL Pro motherboard. –  andrew Dec 26 '11 at 11:02
add comment

3 Answers

Probably while creating the new virtual computer you did not select Windows7 64bit. Create a new one and make sure that you have selected Windows 7(64 bit) from the drop down box.

enter image description here

It can also be that virtualization is not active in your computer or that your simply does not support it, to check if you system supports virtualization run this command

grep ^flags /proc/cpuinfo | head -n1 | egrep --color=auto ' (vmx|svm) '

and look for vmx or svm, if any of those shows up your system supports it.

If it does and you have selected the right template for the virtual guest then probably your BIOS has it disabled.

Have a look in your BIOS options or drop a comment in your question mentioning which computer model / motherboard you have.

share|improve this answer
    
thanks works fine –  Roshan Feb 7 '13 at 8:19
add comment

You are not installing Windows 7 on Ubuntu as a software, you are installing inside VirtualBox.

Enable the virtualization setting inside your computer BIOS. After that, you may install 64 Bit Windows 7 inside VirtualBox.

share|improve this answer
add comment

Turn off Hyper Threading (HT) technology in the BIOS setting and VirtualBox will install any x64 OS without any VT-X pop ups as well. Worked for me on a x64 intel i5 machine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.