Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a lenovo thinkpad and the center scrolling button isn't working with the trackpoint anymore... it worked in prior versions of Ubuntu with GPointing Device Settings, but not with 10.10.

Now, it works when I log in, but if i close the lid to my laptop and reopen it, it no longer works. I have to log out then back in. also, i can not uninstall GPointing Device Settings and reinstall because of this error:

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks. Please report this error at http://launchpad.net/aptdaemon/+filebug and retry.

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 936, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the linux-image-2.6.32-24-generic-pae package. This might mean you need to manually fix this package.

Any ideas? Also, the center click is working like clicking the center of a scroll button it seems. Like, in Chrome, clicking a link opens it in a new tab, etc. How can i fix this?!

===HOW I FIXED IT=== As per the answer i checked as correct i did the following steps in Ubuntu 10.10 and it seemed to work.

First: Go to (in terminal)

/usr/share/X11/xorg.conf.d

Next: create a file named (as root)

20-thinkpad.conf

Next: Add the following to the file:

Section "InputClass"
    Identifier  "Trackpoint Wheel Emulation"
    MatchProduct    "TPPS/2 IBM TrackPoint|DualPoint Stick|Synaptics Inc. Composite TouchPad / TrackPoint|ThinkPad USB Keyboard with TrackPoint|USB Trackpoint pointing device|Composite TouchPad / TrackPoint"
    MatchDevicePath "/dev/input/event*"
    Option      "EmulateWheel"      "true"
    Option      "EmulateWheelButton"    "2"
    Option      "Emulate3Buttons"   "false"
    Option      "XAxisMapping"      "6 7"
    Option      "YAxisMapping"      "4 5"
EndSection

Next: Save the file

Lastly: Reboot your computer! (or manually save and reboot Xorg)

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

You might want to check ThinkWiki's page for instructions on how to configure TrackPoint scrolling.

share|improve this answer
    
Thanks a lot! Manually just making it seemed to work :) –  Oscar Godson Oct 21 '10 at 6:06
add comment

For people searching through the answers: this applies to Dell's DualPoint Stick as well, for this use the following xorg.conf-snippet:

Section "InputClass"
    Identifier      "Scroll w/ DualPoint Stick"
    MatchIsPointer  "on"
    MatchProduct    "DualPoint Stick"
    Option          "EmulateWheel" "on"
    Option          "EmulateWheelButton" "2"
    Option          "EmulateWheelTimeout" "200"
    Option          "XAxisMapping" "6 7"
    Option          "YAxisMapping" "4 5"
EndSection
share|improve this answer
add comment

sudo apt-get install gpointing-device-settings

system > preferences > pointing devices

select TrackPoint on left hand side: check "Use Wheel emulation" in button dropdown menu select '2' click OK

should work now try it out. or follow the link jumpnett posted

share|improve this answer
add comment

I don't know how to fix your problem, but the best place to ask is our bug tracker. If this is your first Ubuntu bug, check out Reporting Ubuntu Bugs for easy instructions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.