Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As I'm not a professional or expert user on Linux at all I need serious help that is easy to understand and easy to implement: I was editing pictures with gimp and then wanted to save them on my USB flash-drive. I then got the information that it's impossible since the file is a read-only file.

Is that normal? can anyone please tell me how to clear this status so that i can save them on my USB flash-drive? I'm running the latest version of Ubuntu.

Thanks so much in advance!

share|improve this question
    
Normally USB drives are mounted read/write able. Can you please check if the lock in your drive (if it exists) allows you to write in it (some drives have a small switch in them that enables/disables writing) can you please add the output of sudo fdisk -l to your question? (Edit your question by pressing the `edit link under it or here. –  Bruno Pereira Dec 6 '11 at 9:46
    
Your USB stick needs a check. Apart from the instructions by Bruno, you can also open the Disk Utility tool and check the USB stick for possible errors. In the Disk Utility you select to 'unmount' first the USB stick, then perform a check. Then, mount it back so that you can use it. –  user4124 Dec 6 '11 at 10:01
    
It might also be that the original file you are editing is read only. Does a simple "save-as" with a different name make any difference? –  John T Dec 6 '11 at 11:08

1 Answer 1

I get this once in a while, when I forget to eject the drive properly. First, look at the USB drive and see if it has some kind of switch. This usually toggles read-only mode.

If that doesn't do it, the easiest fix (for me) is to just reformat the drive.

Back up anything on the drive that you want to save, before continuing.

Just copy things to your desktop, this only takes a minute and you can put the files right back.

Open the dash, it's at the top left of your screen like this:

Dash Home

Type Disk Utility, like this, and select it to open the program.

Disk Utility being selected

  1. Find the drive in the list on the left
  2. Select the partition to be reformatted, in this example there is only one partition.
  3. Unmount the Volume (you can't work on mounted volumes)
  4. Select Format Volume

Disk Utility window

This opens up a window where you choose the type of volume.

  1. Go to the pull-down menu that says Ext4.
  2. Change it to FAT
  3. Click Format

Selecting volume type

Then, click Format on the confirmation dialog to continue.

Confirmation dialog

This should solve the problems now. Good luck.

share|improve this answer
    
+1 for all the screenshots. –  Scott Severance Dec 6 '11 at 12:17
    
thanks so much four your help tom, which i found quite useful and easy to follow. regrettably format to FAT didn't work out! i got the following information: Error creating file system: helper exited with exit code 1: helper failed with: Total number of sectors (4016096) not a multiple of sectors per track (62)! Add mtools_skip_check=1 to your .mtoolsrc file to skip this test mkfs.vfat 3.0.7 (24 Dec 2009) --- so what does that mean? –  Saskia Dec 6 '11 at 14:10
    
sorry tom! i obviously got the information that there was a problem when formatting my drive, but still the volume has changed into FAT. so despite the error message it worked out and it obviously solved the problem! i tried to save my pictures on it and it worked. thanks so much! –  Saskia Dec 6 '11 at 14:35
    
Glad to help. I have no idea what that error means. Maybe someone else can explain? For now just ignore it and keep good backups of your important files. –  Tom Brossman Dec 6 '11 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.