Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when i try to connect ubuntu on ec2 I get the following message

New release 'natty' available.
Run 'do-release-upgrade' to upgrade to it.

But when i try to run this command I get this message:

This session appears to be running under ssh. It is not recommended 
to perform a upgrade over ssh currently because in case of failure it 
is harder to recover. 

If you continue, an additional ssh daemon will be started at port 
'1022'. 
Do you want to continue? 

It says that "It is not recommended to perform a upgrade over ssh". If i can't run this over ssh, Whats the other alternative to update my Ubuntu. Also, I really don't want to loose my data on ec2.

share|improve this question

migrated from serverfault.com Dec 5 '11 at 22:32

This question came from our site for professional system and network administrators.

2 Answers 2

Create an amazon image (AMI) of the server and then perform the upgrade. If it fails, replace the server from the image and come back here and ask again. If it works, be happy.

share|improve this answer
    
Never hurts to have a backup! –  Jeff Ferland Dec 5 '11 at 18:53
    
Two are better. –  mailq Dec 5 '11 at 22:26
2  
I never have fewer than 9 backups - with at least 3 with reads of the binary data on the HDDs chipped into stone tablets by an order of monks who specialize in that sort of thing. –  Driftpeasant Dec 5 '11 at 22:28

When connecting over ssh launch "byobu". This is a tool that keeps your processes alive (by detaching them from your current session) after possible network disconnects. When you reconnect to the server you are automatically reattached to your previous session..no harm done.

More info can be found on https://launchpad.net/byobu

Note that the tool comes standard with Ubuntu repositories, so it should be a fuzz to install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.