Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 on a separate partition. Unfortunatelly after installation I couldn't see grub menu. Ubuntu starts automatically. Then I installed the boot-repair and repaired by this software my grub. Now I can see grub menu, but there is no windows entry. Just ubuntu.

share|improve this question
    
please run the bootinfo script and add the output to your question: sourceforge.net/projects/bootinfoscript –  fossfreedom Dec 5 '11 at 21:58
    
paste.ubuntu.com/760911 here is info generated by boot-repair. –  MariuszPaleo Dec 6 '11 at 7:08
    
looks like you have overwritten the windows 7 boot loader - have a look at this forum entry fix your windows 7 boot loader (ubuntuforums.org/showthread.php?t=1014708). when you have done that, use this question & answer to use the windows boot loader: askubuntu.com/questions/62440/… –  fossfreedom Dec 6 '11 at 23:53
add comment

3 Answers 3

The latest Ubuntu installation seems to do all kinds of wild things if you have multiple drives and such. Your GRUB was most likely installed on the wrong HD. I found it easiest to just partition the space myself using a GPARTED cd, and then reinstalling Ubuntu. There's an option when it asks you if you want to install it side-by-side with Windows that let's you manually select your partition and also the drive grub will be installed on.

share|improve this answer
add comment

I have resolved a Grub menu issue (Ubuntu 11.04 + Win7) with a software Grub Customiser. Good luck.

share|improve this answer
    
Hot to do that? I have installed this software. What should I do next? –  MariuszPaleo Dec 6 '11 at 7:47
    
IN Grub Customiser use Preferences button, than choose Advanced. From there change a default entry to number which corresponds to your Windows partition. (a numbering begins from zero (0)). –  Vincenzo Dec 6 '11 at 20:00
add comment

This has happened to me several times when setting up multi-boot systems and I have always been able to fix it by running sudo update-grub.
Fortunately, update-grub is very straightforward and it will tell you exactly what it is putting in your GRUB menu, including Windows. I have seen some CRAZY solutions to this problem proposed on the forums, I've even tried some of them (and they didn't work). You really owe it to yourself to try update-grub before anything else though.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.