Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a very old RS232 serial tablet (an AceCad III). It does work in Ubuntu, because I've been able to get it to work by disabling hotplug in the X server, but I'd rather leave input device hotplug enabled.

It seems like an InputClass section is what I want. My question is, how do I get the X server to recognize my serial device (it obviously can't autodetect it)? I tried inputattach --dump /dev/ttyS0 but X didn't seem to pick it up (nothing in the log files).

For reference, here's the InputClass section I'm using:

Section "InputClass"
        Identifier  "AceCatIII"
        Driver      "mouse"
        MatchDevicePath "/dev/ttyS0"
        Option      "Protocol" "AceCad"
        Option      "Device" "/dev/ttyS0"

I'm on a fresh install of 11.10.

share|improve this question

closed as too localized by Marco Ceppi Mar 5 '12 at 18:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Marco Ceppi Mar 5 '12 at 18:00