Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Lenovo S12 (Intel Atom) running 11.10 Unity desktop will not hibernate.

If I use the Shutdown/Hibernate option, it will go to a blank screen with an flashing underscore cursor in the upper left of the screen. If I power-off then using the power button on the laptop, it will shut off but does not restore the session.

How can I get this to work as designed?

Added note:

I tried the solution here, but it didn't work. After this, instead of hanging with the flashing underscore cursor, it now hangs with the following text...

Looking for splash system... none
s2disk: Snapshotting system

Also the /etc/fstab now shows six swap partitions instead of the one swap partition used before a clean install from an 11.04 prior installation. I have fixed the swap partition, now have a single, dedicated swap partition.

Fixing this did not solve the hibernate problem.

Another added note: The only proprietary driver on the system is the "Broadcom 802.11 Linux STA wireless…"

share|improve this question
    
Once you have fixed the swap partition issue as detailed in other questions does the system then work as expected? - with six swap partitions I'm not surprised it didn't work... –  Mark Rooney Dec 5 '11 at 20:58
    
Apparently this is a known bug. bugs.launchpad.net/ubuntu/+source/uswsusp/+bug/771242 –  keepitsimpleengineer Jan 9 '12 at 17:18
    
@Mark Rooney - Actually 11.10 ran with six swap partitions, it only used one and the others just wasted disk space. And no, it didn't hibernate after getting rid of the superfluous swaps. I'm familiar with multiple swaps from prior work with other UNIX systems, back in the day when memory was expensive. –  keepitsimpleengineer Jan 30 '12 at 21:25

2 Answers 2

Press and hold the power button for a count of roughly 10. That should actually power the device off instead of hibernating again. Then you need to do some troubleshooting with Hibernate.

share|improve this answer
up vote 0 down vote accepted

This is a known bug. There is no workaround. Confirmed but with no one assigned and undecided importance.

Showstopper for 11.10 on a laptop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.