Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed 11.10 fresh but with a previously used /home/bob directory mounted.

unity does not start when i log in as 'bob', but does work as a guest, as well as for a new users account i made, 'bob2'.

if i start in 2d then run unity from command line, it works (this is my current work-around).

things i have tried:

  • unity --reset

  • removed all settings directories (rm -rf .gconf .gnome2 etc)

  • installed ccsm and un/re-enabled unity, and removed conflicts (there were some)

none seem to solve the problem. any ideas?

share|improve this question
    
Did you try removing the ~/home/bob/.compiz-1 folder? –  htorque Feb 25 '12 at 21:31
add comment

1 Answer

Removing .Xauthority and ~/.config/autostart fixed the problem.

rm ~/.Xauthority
rm -rf ~/.config/autostart 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.