Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu 64-bit 11.10 installed box has 6GB RAM but Ubuntu only uses 4.1GB.

I have read various things about the 4GB limit etc, but all those talk about using less than 4GB.

What could be causing this?

My Hardware:

  • Asus P5Q Pro
  • Intel Core 2 Quad Q6600 @ 2.40GHz x4
  • GeForce 9600GT (1024MB) Card not integrated
  • 3x 2GB DDR2 RAM Modules - PC-6400

Output of uname -a

Linux ASUS-P5Q-PRO 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
share|improve this question
    
Do you integrated graphics? If you do some of your ram will go to that. The only way to prevent this is to get a graphics card. –  TheX Dec 5 '11 at 16:37
    
@TheX no I don't. Will add that to question! Meant to anyway... –  neildeadman Dec 5 '11 at 16:41
    
Possbile Duplicate –  Marco Ceppi Dec 5 '11 at 16:43
    
Not a duplicate as that is talking about over 3GB when I am discussing not over 4.1GB and that is because they have integrated graphics, which I don't. –  neildeadman Dec 5 '11 at 16:48
    
Just wondering if the os isn't running on part of the ram ? ( if it's a graphical shell then i'd think that it'd take up around 500Mb or more ( especially with unity ) ) since you can't kill your os it also won't show in any processor lists and as such be "disapearing ram" ? ( just my 50 cent ) –  Peter Vermeulen Dec 5 '11 at 16:50

2 Answers 2

Check in the BIOS to see if there is a setting for 32-bit & 64-bit HPET timer. I've found when the HPET is set to 32-bit, it tends to not address all of the memory available. I don't know how a timer can play in this, but make sure it is set to 64-bit. I could be reaching here, but it's worth a shot.

@jpyper on Twitter.

share|improve this answer
    
Although your answer wasn't the solution... it lead me to finding the problem... so thanks! :) –  neildeadman Dec 7 '11 at 8:52
up vote 1 down vote accepted

In my question above, I stated that the BIOS saw the 6GB. I said this because when booting, as it showed the device info etc before booting, it listed 6GB of RAM.

John suggested I look for a setting for HPET and in doing so, I discovered that the BIOS Setup was reporting that the only usable amount of System Memory was something like 4.3GB.

This obviously shows it wasn't a Ubuntu problem (wish I'd found this sooner!) and replaceing one of the 2GB sticks for 2x 1GB sticks gives me the 6GB I was looking for.

My memory config before was:

DIMM0: 2GB DDR2
DIMM1: 2GB DDR2
DIMM2: 2GB DDR2
DIMM3: EMPTY

My configuration now is:

DIMM0: 2GB DDR2
DIMM1: 1GB DDR2
DIMM2: 2GB DDR2
DIMM3: 1GB DDR2

This only came about because I had to remove a faulty stick! But at least it's sorted now!

share|improve this answer
    
This May invoke a GIYF from some. But I have tried half a dozen tricks and still my Toshiba Satelitte 630c with Ubuntu 11.10 is unable to use the 6GB (2GB + 4GB Dimm) . However, if you're to suggest conflicting freqs..its not as my Machine detects 2.3 GB of RAM... –  Nocturnalknight Mar 27 '12 at 6:35
    
what happens if the 4gb stick is in on its own? –  neildeadman Mar 27 '12 at 7:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.