Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 on a netbook with 1 GB RAM and a single-core 1.66 GHz Intel Atom processor. If I have too many things running at a time, the system becomes quite slow (disk I/O seems to be the bottleneck), so I am careful to avoid this. Naturally, I want to be in control of when resource-hungry things run.

I do all my package management from the terminal. I use Byobu, and have set it to show the number of packages to be upgraded in the bottom row.

Every now and then Update Manager pops up to inform me about updates. This seems to be an a very resource-hungry application - it causes disk thrashing, and the window starts out as being unresponsive (Compiz makes it grey), and takes a long time to start accepting mouse input. This causes a disruption in whatever I'm doing, and the Update Manager doesn't even go away quickly after I click the cross button in the title bar.

So here is what I want:

  • The system should automatically check for updates as it does now. This is fine.
  • The Update Manager window should never open unless I manually open it. I can see that there are packages to upgrade at the bottom of my terminal window, and I don't want the system to spring bloated GUI windows on me when I'm not expecting it.

Is there a way to do this? I guess I could disable the Update Manager automatic checks and learn about cron and use that to do a aptitude update at regular intervals... but there should be a better, more direct way! But there is no "do nothing" option in the dialog box below:

Update Manager window

share|improve this question
    
What could possibly be more "direct" than using a cronjob that executes one simple command? –  imbaer Dec 5 '11 at 14:10
    
Are you sure the update manager is what causes the slowdowns? Can you verify that it does, because I very much doubt it is at fault. What you may experience, prior to the Update Manager opening, is the update-apt-xapi bug. bugs.launchpad.net/ubuntu/+source/apt-xapian-index/+bug/830333 If that's the case, remove the apt-xapian-index package. Needless to say that Compiz is the first thing you should be worried about if concerned about resources. –  mikewhatever Dec 5 '11 at 14:38
    
@s4ms3milia : Good point. I meant direct with respect to the usual Ubuntu user experience, without the need to bypass whatever Update Manager does. –  Prateek Dec 5 '11 at 14:56
    
@mikewhatever : It definitely happens consistently when Update Manager opens. I don't know if the issue is with update-manager or apt-xapian-index, though. I quite like Compiz and overall I have a setup that works well for me. Except for Update Manager's intrusions. –  Prateek Dec 5 '11 at 14:58
    
If you don't know, then go ahead and find out, or else, believe what you want to. ~:) –  mikewhatever Dec 6 '11 at 6:03

1 Answer 1

up vote 4 down vote accepted

You can change this behaviour with dconf Editor. Install the package dconf-tools. Start dconf Editor from Dash, navigate to com -> ubuntu -> update-notifier and untick auto-launch.

share|improve this answer
    
Thanks! I am accepting your answer assuming it has the required effect. –  Prateek Dec 5 '11 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.