Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux/Ubuntu. I installed Ubuntu 11.10 on my Lenovo IdeaPad y510.

System info says

Graphics: unknown.  
Driver: unknown,  
Experience: Standard.

What should I do to use all my laptop hardware components to work properly with Ubuntu? Screenshot:

enter image description here

share|improve this question

4 Answers 4

it means that it cannot acquire the information because glxinfo is not installed on the system.

Install it by clicking here:

Install via the software center

Or by typing:

sudo apt-get install mesa-utils

This is bug 914631.

After installing mesa-util it's providing information about graphic. In my case (Probook 4530s) "Intel® Sandybridge Mobile", while experience index still the same: Standard.

share|improve this answer

I have the same graphics device and the "Unknown Driver" problem. This is not a problem with the driver installation but with the fact that Ubuntu is unable to recognize it properly.

If you can see a properly functioning GUI and not a black and white Command-line screen, then your Graphics Card is working fine.

This issue has been frequently discussed: http://ubuntuforums.org/showthread.php?t=1949097

If the graphics performance appears to be poor it may be simply because Precise does'nt have wobbly windows and other special effects enabled by default (or at least not in low end systems). Download Compiz and enable these effects and animations. They should work fine with Intel GMA Integrated Graphics (they do on mine!).

share|improve this answer
1  
To be able to recognize it install mesa-utils , compiz IS already install in 12.04 as Unity IS a compiz plug in, what it's not installed is the settings manager, effects like the wobbly windows are not enabled by default on the installation. –  Uri Herrera Jun 16 '12 at 7:57
    
Unity may be a Compiz plugin but I don't think Compiz Settings Manager is installed by default in Ubuntu. –  upapilot Jun 16 '12 at 8:24
1  
Yes that's what i said. –  Uri Herrera Jun 16 '12 at 9:01
    
Get th latest Kernel, the Intel drivers are in the Kernel –  Uri Herrera Jun 16 '12 at 18:39
    
@UriHerrera, please add your comment in a question, i worked –  Anwar Shah Jun 19 '12 at 7:55

For Ubuntu to show the correct information in the details window, You should install the package mesa-utils.

Open a terminal and execute the following command:

sudo apt-get install mesa-utils
share|improve this answer
4  
and this is not installed by default, why? –  waspinator Aug 31 '12 at 18:43

Install Mesa-Utils by running these commands:

sudo apt-get update
sudo apt-get install mesa-utils

Then it will be detected.

share|improve this answer
3  
+1 this is a know bug. The card is detected by the system but not shown on the GUI. As stated in the answer installing mesa-uitls will get the card to show. You may also want to see my answer here on installing the texture compression libs that will allow you to play the newer games that require s3tc support. –  TrailRider Jul 7 '12 at 15:09
1  
Thank you for answer, after I install mesa-uitls the system can get the card to show and I will have a look. –  user66498 Jul 7 '12 at 17:45

protected by Community May 1 '12 at 11:28

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.