Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The thing is my Ubuntu 11.10 does not boot properly, each time I try to boot, the Ubuntu logo appears for a brief time, a very small loading happens, then a black screen appears with things like the following:

* Stopping anac(h)ronistic cron              [OK]
* Starting anac(h)ronistic cron              [OK]
* Stopping cold plug devices                 [OK]
* Stopping log initial device creation       [OK]

I've noticed that the lines I get vary, sometimes I also have additional lines like:

* Starting the Windbind daeomon winbind      [OK]
* PulseAudio configured for per-user sessions sand disabled; edit /etc/default/saned   [OK]
* Starting CUPS printing spooler/server      [OK]

Things i did: I installed some packages using synaptic, packages that allow me to install .tar.gz, the installation went good, but when i restarted my computer I was unable to boot i don't know if this has anything to do with my problem

Fixes i tried: I tried to update then upgrade, still same problem. I tried to boot from Live USB and ran dpkg fix and the other one for the boot file, still same problem

Recovery mode gives me the same problem

Any help please?

share|improve this question
    
I get this too, but it's intermittent. Maybe 1 in 10 boots. –  Tom Brossman Dec 5 '11 at 14:22
    
Edited title, added: (lightdm issue) –  david6 Dec 5 '11 at 22:03
    
What is your exact graphics chip? Please add output from: lspci –  david6 Dec 6 '11 at 0:02

2 Answers 2

Answer edited out from the question:

I found a partial fix and just in case anyone else is having the same problem which is extremely annoying.

It turned out to be an issue with Lightdm. Anyway to fix this, I removed lightdm and went back to using GDM which is GNOME display manager. It's extremely ugly but at least it lets you boot.

In order to do that you should follow these steps:

  1. When in the black ugly screen hold down Ctrl + Alt + F1. If nothing happens hold F2 instead.

  2. Enter your credentials

  3. sudo vi /etc/X11/default-display-manager

  4. Change it to /usr/sbin/gdm

    (If you're not familiar with vi: edit, then save by entering : then wq! )

  5. sudo reboot


My answer to the question:

When the loading stops with the 'ugly black screen', enter one of the ttys (for example Ctrl + Alt + F1) and login into your system.

Then enter sudo service lightdm restart

If it says unrecognized service, try the command sudo apt-get install lightdm

This should ensure that Lightdm is properly installed.

share|improve this answer

I suggest you retry everything. Re download it and put it on the the storage device and retry. If that doesn't work, I don't thin the computer is compatible.

share|improve this answer
    
I retried the process several times and had the same result, i don't think it's a compatibility problem, since it was working fine until i thought of changing the background of the logon screen. Form that point on Unity greeter stopped working. –  Ramzi Njeim Dec 15 '11 at 23:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.