Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A recent update (Ubuntu 10.04) has caused my Trash bin to be renamed to "Rubbish Bin".. I don't like this new name. How can I change it?

I've tried: gconf-editor -> apps/nautilus/desktop -> trash_icon_name
but that didn't work.

Also, $HOME/.config/user-dirs.dirs has no entry for the Trash directory...

share|improve this question
    
I like 'Rubbish Bin', sounds so Australian. :~) –  mikewhatever Dec 5 '11 at 4:49
    
@mike. I completely agree with you. It is very Australian, but because of that is stronly means rubbish which has been totally rejected, eg; domestic food waste, etc... I always Shift-Delete my rubbish files.. For me, my Trash-1000 is solely for my potentially recycleable files. I can happily live with 'trash', as here it loosely means hard-rubbish, and "trash it!" means "destroy or wreck it, or chuck it out!" ... but I don't want to go rummaging through my rubbish :) –  Peter.O Dec 5 '11 at 5:36
    
A different interface language should solve it, if that is an acceptable solution. You'll get 'Trash' with English USA, that's what I use. –  mikewhatever Dec 5 '11 at 6:49
    
I'm don't know if this is the problem, but regardless of all other locale values being set to US (now), this line export LANGUAGE="en_US:en" in my ~/.profile has no effect, and I still wind up with LANGUAGE="en_AU:en" in my bash locale output. So something seems to be changing LANGUAGE to AU after ~/.profile is run, but I don't know where. It isn't in my /bashrc... and this has only happened since I rebooted yesterday (after updating 2-3 days ago)... –  Peter.O Dec 5 '11 at 9:47

4 Answers 4

up vote 3 down vote accepted

There is an option to select the interface language at the login screen. I've just tried loggin out and selecting Australian English, and now have the 'Rubbish Bin' in Nautilus. Select English USA and you should get 'Trash'.

share|improve this answer
    
That worked... Thanks.. you've saved the day (well, mine at least ) ... my logon bypasses all the option stuff: its good to know those options are there. –  Peter.O Dec 5 '11 at 14:38

Sounds like you may have set yourself to a different location (eg. UK) as I believe that is the name for it when using UK english.

share|improve this answer
    
Interesting.. I'll check that out.. I haven't changed anything myself, though something else may have... (I"m back) .. I've checked my locale and it looks the same as before: all AU.. eg. LANG=en_AU.UTF-8 LANGUAGE=en_AU:en LC_CTYPE=en_AU.UTF-8 .. But in any case, Is there some way you know of to change only this Trash title. –  Peter.O Dec 5 '11 at 4:47
    
PS.. I don't know my locale settings particularly well, but I must say that LANGUAGE=en_AU:en looks a bit unfamiliar to me.. I thought (prior to this) that all my settings were suffixed with UTF-8.. but I'm not 100% sure of that, and I don't know how or what to check... I just checked a 10.04 VM and it doesn't have have the LANGUAGE= setting... The VM's nautilus names the trash directory as: Wastebin –  Peter.O Dec 5 '11 at 5:03

probably the easiest way you can can change it is to install ubuntu tweak and under the desktop icon settings you can name it anything you want.

share|improve this answer
    
matt. thanks for the suggestion, and I appreciate that it may well work, but because I keep away from (most) things which aren't in the repository, and because I really want to know what has caused this and how to fix it more directly (ie. conf files, etc), I'll have to let this option pass... –  Peter.O Dec 5 '11 at 10:35
    
fair enough, I'm pretty sure it is in the repos 10.10 onwards though. I still don't understand why /apps/nautilus/desktop/trash_icon_name isnt working for you. I cant try anything else as I'm not on an Ubuntu machine. –  matt Dec 5 '11 at 11:07
    
you changed the value form integer to string yes? Oh and this would only change the desktop icon and not the panel icon name. –  matt Dec 5 '11 at 11:13
    
@matt: Yes, it is definitely set: gconftool-2 --get /apps/nautilus/desktop/trash_icon_name returns my value of TRASH, but I don't have any desktop icons (I favour the keyboard), and icons spoil my desktop pic, which at the moment happens to be a picture of midnight on a moonless starless night in the middle of an arctic winter, sort of the opposite of a polar bear in a blizzard. :) .. but, thanks for the good suggestions ... I hadn't realized it only applied to the desktop icon (although the key-name is a bit of a give-away, come to think of it) –  Peter.O Dec 5 '11 at 12:04

have you tried going to system settings > language support and putting english at the top of list? (u need to log out and log back in for these settings to take effect)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.