Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I copied A set of BlueJ files from /usr/share/doc/BlueJ to a ~/BlueJ directory however the files in folders are set to root permission and read only I need to be able to read/write them.

So in BlueJ folder there are subfolders for each project for example 'shapes' folder.

I found this command here for changing a singular file File Permissions Ubuntu user@host:/home/user$ sudo chmod o+x /usr/local/bin/somefile

But how can I change the folder permissions and subsequently all files in folders for every project folder in '~/BlueJ'

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Do

sudo chmod -R o+rwx ~/BlueJ

or

sudo chmod -R 755 ~/Bluej

Where -R is for recursive and o+rwx is for others to read/write and execute

Or

If you want to take ownership of the folder and files

sudo chown -R USERNAME.USERNAME ~/Bluej

Where USERNAME is your ubuntu username.

share|improve this answer
    
I strongly suggest you chown them (the final example) rather than set them world writeable. –  Caesium Dec 5 '11 at 3:05
    
Thanks. I followed the chown example and it works perfect. –  sayth Dec 5 '11 at 3:42
add comment

It's easy! You can either do it the way Sagar said, or you could do it from the GUI. Open a terminal

sudo nautilus

Navigate to the folder/file you want to change the permissions of, then right click on it and select "Properties". Once in the properties menu, go to the "Permissions" tab, and adjust your permissions!

And by the way, in the permissions tab, there is an option to apply the options you selected to all files inside that folder, hope it hepled!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.