Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Update Manager keeps opening automatically and it's getting very annoying, especially when I'm using Gnome Shell. How do I make it stop?

share|improve this question

6 Answers 6

up vote 9 down vote accepted

This may work for you. I haven't verified if it works in GNOME.

  • Open the Software Sources application.
  • Select the "Updates" tab.
  • For the "Automatically check for updates" option, select Never.

Picture of Software Sources window, with cursor selecting *Never* for 'Automatically check for updates' option

After this, you will have to open the Update Manager application manually.

share|improve this answer
    
Thanks. This seems to work except when I did a apt-get operation but I think it was because of apt-get update. –  Devon Garber Apr 29 '12 at 15:40
3  
This makes it not update itself, but the GUI will still be popping up if anything else causes an update (e.g. like manually running apt-get update.) –  Bryce Jun 27 '12 at 6:12

I found this post with the following instruction:

open gconf-editor, browse down to Apps -> Update Notifier, and uncheck the auto_launch option


OK, try this one. It's similar to the other answer but disables it instead of deleting it entirely. It might be safer for you to open the file in an editor and change the line by hand instead of the sed command that post uses.

The procedure, using an editor:

  1. Open a terminal
  2. Move to the autostart directory (cd /etc/xdg/autostart) and list the files there (ls).
  3. Find the startup program you want to run (in our case update-notifier.desktop) and open it in an editor (gksudo gedit update-notifier.desktop). Enter your password if necessary.
  4. Be careful not to change anything except this line. Find this line:
    NoDisplay=true
    and change it to:
    NoDisplay=false
  5. Save the file and exit.
  6. Reboot to make sure it worked.
share|improve this answer

Ubuntu 12.04 LTS

The Update Manager pops up when it detects a new update. This behaviour can be pretty annoying for many, especially when you are in the midst of your work. To make it worst, if you close it without updating, it will keep on popping up in regular intervals and each time after boot, until you have upgraded your system. To turn it off:

Method 1 - Disable Update Notifier from autostart

The Update Notifier autostarts on boot and triggers Update Manager. In this method, we prevent the Update Notifier itself from autostarting,so that Update Manager won't be triggered. Edit Update Notifier's entry in systemwide autostarts - /etc/xdg/autostart/update-notifier.desktop ( Note that you wont be able to use the Startup Applications app,as it only deals with per-user autostart entries ) and add the following line:

X-GNOME-Autostart-enabled=false

Reboot now, and you'll find that there's no Update Notification.

Disable Update Manager Popup

Disadvantage: This disables automatic Update Notifications altogether.You'll have to manually check for updates(which is fine by me,but may not be for some people)

Method 2 - Show Update Indicator

This option makes the Update Notifier show an Update Indicator in the panel, instead of popping up the Update Manager. I think this should be the default setting for Update Notifier in Ubuntu. To do it:

Graphical Way: Open dconf Editor. Navigate to com->ubuntu->update-notifier. Uncheck the entry auto-launch and close dconf Editor. To recover the Update Manager popup function, simply repeat the above step, but place a check in the auto-launch entry. Prevent Update Manager Popup

Command Way: For the terminal lovers out there, type in these commands to do the same.

gsettings set com.ubuntu.update-notifier auto-launch false

and to recover:

gsettings set com.ubuntu.update-notifier auto-launch true

These methods were tested and found to be working on Ubuntu 12.04 LTS with update-manager version 0.156.14.11. I got the idea from the post How to Remove The Annoying Update manager Pop-up in Ubuntu Jaunty and simply modified it to work on Ubuntu 12.04 LTS aka Precise Pangolin

share|improve this answer

In Precise, it is done using dconf now rather than gconf.

  1. Install dconf-tools

    $ sudo apt-get install dconf-tools

  2. run dconf-editor and navigate to com > ubuntu > update-notifier.

  3. Tick no-show-notifications

dconf-editor

And here's how to do it from the command line:

dconf write /com/ubuntu/update-notifier/no-show-notifications true
share|improve this answer

In order to stop Update Manager from launching:

gconftool -s --type bool /apps/update-notifier/auto_launch false

To activate it again:

gconftool -s --type bool /apps/update-notifier/auto_launch true

Hope it helps ;)

share|improve this answer

Should be

gconftool -s --type bool /apps/update-notifier/auto_launch false
share|improve this answer
    
Didn't work. Thanks anyway though! –  Devon Garber Mar 7 '12 at 20:51
2  
Perhaps this works on Ubuntu versions prior to 12.04. –  Eliah Kagan Jun 27 '12 at 6:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.