Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had my Canon IP 3100 printer for years, and with every version of Ubuntu, since around 8 or so, it has been auto detected and worked perfectly.

Now, with Ubuntu 11.10, it has been detected as some kind of "generic text only printer", and I can't even print a test page.

I've looked at the printer interface, and there doesn't seem to be any way at all to manually select the right printer driver.

This is all there is in the printer dialogue in the settings manager:

printer dialog

The only place to go is "Options", but if you do that, all you get is this:

printer options

Not much to go on.

I have also tried removing it and reinstalling it, but that has not helped.

How do I get my printer drivers back?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Solution seemed to be a two part thing. One was following the instructions here.

It didn't work at first, though. Part of the key seems to be to not try and install the drivers using the interface above, but instead close that, turn the printer on, and use the dialog that comes up when the printer first connects.

Anyway... had to go back to the command line in 11.10. Not a step forward IMHO. But at least the printer is working now.

share|improve this answer

Click this: http://localhost:631

I had a same problem. But now solved. I also use Ubuntu 11.10(amd64) and Canon iP-3100.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.