Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get this strange error trying to mount UFS partition.

   sudo mount -r -t ufs -o ufstype=ufs2 /dev/sdb2 /home/tim/ufs_mount
   mount: wrong fs type, bad option, bad superblock on /dev/sdb2,
          missing codepage or helper program, or other error
          In some cases useful info is found in syslog - try
          dmesg | tail  or so

I'm a Ubuntu newbie and just switched from FreeNAS.

tim@T3:~$ sudo fdisk -l

Disk /dev/sda: 400.1 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders, total 781422768 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000a77a6

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   765700095   382849024   83  Linux
/dev/sda2       765702142   781422591     7860225    5  Extended
/dev/sda5       765702144   781422591     7860224   82  Linux swap / Solaris

Disk /dev/sdb: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders, total 2930277168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x90909090

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63      240974      120456   a5  FreeBSD
/dev/sdb2          240975  2928601304  1464180165   a5  FreeBSD
/dev/sdb3      2928601305  2930272064      835380   a5  FreeBSD
share|improve this question
    
Are you sure it's a UFS partition? Post the output of sudo fdisk -l. –  waltinator Dec 5 '11 at 1:09
    
Actually im not sure anymore. I successfully mounted another partition from another disk. More info about that in this question. –  Tim Dec 5 '11 at 10:50
add comment

3 Answers 3

up vote 5 down vote accepted

You need to get the bsd partition, that fdisk -l cant show you.

First:

$ dmesg|grep bsd

[    3.467958]  sde1: <bsd:bad subpartition - ignored
[    3.467959]  sde2: <bsd: sde5 >

Look after a partion, in this case sde5 seemed to be the one fore me.

Then:

$ sudo mount -t ufs -r -o ufstype=ufs2 /dev/sde5 ~/freebsd

The forum answer that got me on the right track

share|improve this answer
add comment

There are many types of the UFS file system, those many are supported by the Linux Kernel but its very hard to automatically detect which type of UFS needs to be mounted, that is why you need to add the ufstype= argument to the mount command.

Possible common types are:

  • old old format of ufs
  • default value, supported as read-only
  • 44bsd used in FreeBSD, NetBSD, OpenBSD
  • ufs2 used in FreeBSD 5.x
  • 5xbsd synonym for ufs2
  • sun used in SunOS (Solaris)
  • sunx86 used in SunOS for Intel (Solarisx86)
  • hp used in HP-UX
  • nextstep used in NextStep
  • nextstep-cd used for NextStep CDROMs (block_size == 2048)
  • openstep used in OpenStep

Since you are comming from FreeNAS and that is based on FreeBSD I recommend you try ufs2 or 44bsd in the ufstype= parameter.

More information here in the Linux Kernel documentation.

share|improve this answer
    
Hi Bruno! Nice to see you again! I tried this yesterday actually, but none worked :( –  Tim Dec 5 '11 at 20:58
    
I am shocked :( Ill look for a better way of identifying the UFS type and add a comment if I find anything else. –  Bruno Pereira Dec 5 '11 at 20:59
    
That would be very nice of you! Another though might be if there is some way to check for errors in the partition somehow? Maybe there is something wrong with the "superblock"? –  Tim Dec 6 '11 at 21:01
    
Think there is a package called ufsutils with a fs checker, not 100% sure about the name atm, loof for ufs in the Ubuntu Software Center. –  Bruno Pereira Dec 7 '11 at 6:58
add comment

We have the same experience a few days ago, i got the same error but after i check it in the mount target directory it mounted the ufs even theres an error in the mount command.

Check the mount target if it mounted even if has error showed when mounted.

share|improve this answer
    
Thanks for your answer, but there was nothing mounted. –  Tim Dec 5 '11 at 20:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.