Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 10.10 on an hp dv4 and my wifi was working just fine(except the wifi led blinking) till yesterday. Now when I touch the wifi button it just won't switch ON!!! :o I didn't make any changes yesterday but updated my system today.

I have no idea what happened. Any clue???

I ran the command sudo lshw and got its output as:

*-network DISABLED
            description: Wireless interface
            product: AR9285 Wireless Network Adapter (PCI-Express)
            vendor: Atheros Communications Inc.
            physical id: 0
            bus info: pci@0000:02:00.0
            logical name: wlan0
            version: 01
            serial: 90:4c:e5:58:14:34
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list
            ethernet physical wireless
            configuration: broadcast=yes driver=ath9k
            driverversion=2.6.35-22-generic
            firmware=N/A latency=0 link=yes
            multicast=yes wireless=IEEE 802.11bgn
            resources: irq:17 memory:96400000-9640ffffmemory:96400000-9640ffff

The network is disabled?!? :o i tried to enable it by right clicking on network manager but the Enable wireless button has been greyed out.

I opened the file /var/lib/NetworkManager/NetworkManager.state and found that the contents are

[main] NetworkingEnabled=true WirelessEnabled=false WWANEnabled=true

I tried to change WirelessEnable=false to WirelessEnabled=true but after reboot it resumed back to the same state.

share|improve this question
    
That stupid touch-sensitive button has got to be the worst idea ever in the history of computer case design. –  Pointy Oct 20 '10 at 16:27

1 Answer 1

up vote 2 down vote accepted

Try rebooting. If it's still offline after the reboot, press the wifi button once more and restart again.

I had a similar issue with this on my dv5.

share|improve this answer
    
it didn't work for me :( –  Gayathri Oct 20 '10 at 17:16
    
ok! it worked today :o –  Gayathri Oct 21 '10 at 12:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.