Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 yesterday, and have been struggling with enabling desktop effects for hours. I downloaded the CompizConfig Settings Manager, and tried selecting-deselcting various items. But they don't seem to be taking effect. Please help. Thanks.

VGA: 00:02.0 VGA compatible controller: Intel Corporation 82946GZ/GL Integrated Graphics Controller (rev 02)

EDIT:

New problem! I made a few changes in CompizConfig settings, and a few effects started working. Like wobbly windows, and rotating cube.

Then I tried enabling a few application switchers, and it asked me to resolve the conflicts. I guess one of them was "enable OpenGL".

As I clicked it, everything crashed. Dock vanished. I only a see one bar at top with menus File, Edit, .., Bookmarks, Help.

I am not able to access anything else. [Alt] + [F2] and [Super], both are not working. What do I do? Please help! (Right now I am accessing web via a guest account. To get any work done, I have to be able to use my own account again.)

share|improve this question
    
What video card do you have ? lspci | grep VGA –  bodhi.zazen Dec 4 '11 at 6:39
    
@bodhi.zazen: 00:02.0 VGA compatible controller: Intel Corporation 82946GZ/GL Integrated Graphics Controller (rev 02) –  missingfaktor Dec 4 '11 at 7:13
    
@bodhi.zazen: I should perhaps mention that I was a Linux Mint user for over 2 years and all desktop effects worked flawlessly. Never had issues. –  missingfaktor Dec 4 '11 at 7:14
    
@bodhi.zazen: Please see the updated question. –  missingfaktor Dec 4 '11 at 9:20
1  
@severin: Marc Simpson (korsch on twitter) helped me out. twitter.com/#!/korsch/status/143381598325309441. –  missingfaktor Dec 4 '11 at 18:07

2 Answers 2

May be you should look into the additional drivers that might be required to enable desktop effects. System->Administration->Additional Drivers.

Alos look at this documentation page Restricted Drivers

share|improve this answer
    
"No proprietary drivers are in use on this system." –  missingfaktor Dec 4 '11 at 8:42
1  
Intel GPUs don't need that option –  Uri Herrera Dec 4 '11 at 8:47
    
may be you can refer this link [askubuntu.com/questions/83379/… –  techubuntu Dec 4 '11 at 9:00
    
@techubuntu: Please see the updated question. –  missingfaktor Dec 4 '11 at 9:20
    
@Uri: Please see the updated question. –  missingfaktor Dec 4 '11 at 9:20
up vote 0 down vote accepted

I reset my Compiz settings using the commands provided in this blog post, and it worked.In particular, the following command did the trick:

gconftool-2 --recursive-unset /apps/compiz-1
unity --reset
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.