Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to linux. I was using fedora and now switching to Ubuntu for a try. On Fedora my wireless network card was working OK from the OS install (I didnt had to do anything for it to work) On Ubuntu, with the lspci -v command, I get:

Network controller: Ralink corp. RT3060 Wireless 802.11n 1T/1R
    Subsystem: Ralink corp. RT3060 Wireless 802.11n 1T/1R
    Flags: bus master, slow devsel, latency 64, IRQ 20
    Memory at fe9e0000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: rt2800pci
    Kernel modules: rt2800pci

But I am not able to find any wireless network. What to do now?

Thanks

share|improve this question
    
The following resources can help update these answers: ubuntuforums.org/showthread.php?t=2020237 answers.launchpad.net/ubuntu/+question/191011 wiki.debian.org/rt2800pci –  Jorge Castro Aug 13 '12 at 15:37

3 Answers 3

up vote 2 down vote accepted

For 11.10:

There appears to be an issue with the RT3060 wireless card in 11.10 - it defaults to the 2800 kernel module which is incorrect.

Connect via your fixed wired link and run:

wget http://media.cdn.ubuntu-de.org/forum/attachments/2814031/angepasster-DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217.tar.gz
tar xzvf angepasster-DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217.tar.gz

Run the following (copy and paste) into a terminal - N.B. you'll need to do this each time there is a Kernel update.

sudo apt-get install --reinstall linux-headers-generic build-essential dkms
cd angepasster-DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217/
sudo make
sudo make install
echo "blacklist rt2800pci" | sudo tee /etc/modprobe.d/blacklist-rt2800pci.conf
sudo modprobe -rfv rt2800pci
sudo modprobe -v rt3562sta

This should make the wireless card work ok.

If you have wireless drop-outs then you'll need to disable power-management

gksudo gedit /usr/lib/pm-utils/power.d/wireless

change this part:

case $driver in
ipw2100) iwpriv_ac="set_power 0"
iwpriv_batt="set_power 5"
iwconfig_ac="power on"
iwconfig_batt="power on";;
ipw3945)
iwpriv_ac="set_power 6"
iwpriv_batt="set_power 7";;
iwl*) if [ -f "/sys/class/net/$1/device/power_level" ]; then
iwlevel_ac=0
iwlevel_batt=3
else
iwconfig_ac="power off"
iwconfig_batt="power on"
fi;;
*) iwconfig_ac="power off"
iwconfig_batt="power on";;
esac

to:

case $driver in
        ipw2100) iwpriv_ac="set_power 0"
            iwpriv_batt="set_power 0"
            iwconfig_ac="power on"
            iwconfig_batt="power on";;
        ipw3945)
            iwpriv_ac="set_power 6"
            iwpriv_batt="set_power 6";;
        iwl*) if [ -f "/sys/class/net/$1/device/power_level" ]; then
                 iwlevel_ac=0
                 iwlevel_batt=0
              else
                 iwconfig_ac="power off"
                 iwconfig_batt="power off"
              fi;;
        *) iwconfig_ac="power off"
           iwconfig_batt="power off";;
    esac

More information and possible wireless-N workarounds are described in the source of this answer.

share|improve this answer

For 12.04:

  • The only official support for the RT3060/3062/3562/2592 in Linux is experimental and may not be fully functional.
    • This is provided by the rt2800pci driver from the kernel.org/compat-wireless team
    • The driver is an independent effort and does not seem to use Ralink code

Option 1. Try installing the latest compat-wireless backports package and see if it works

  • Click the below to install it via the Software Center:

    Install via the software center

  • Alternatively, open a terminal with Ctrl+Alt+T and paste:

    sudo apt-get install linux-backports-modules-cw-3.3-precise-generic
  • Once installation is complete, reboot and see if your wireless card works better. If not, follow option 2.

Option 2. Build and install Ralink's own drivers

  1. Download them from Ralink's website.
  2. Save to your Downloads folder (default):

    enter image description here

  3. Open a terminal with Ctrl+Alt+T, and paste the following, line by line:

    sudo apt-get install linux-headers-$(uname -r) build-essential dkms
    cd Downloads
    tar -xzf DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217.tgz
    cd DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217
    WPA1=HAS_WPA_SUPPLICANT
    WPA2=HAS_NATIVE_WPA_SUPPLICANT
    sed -i -e "s/$WPA1=n/$WPA1=y/g" -e "s/$WPA2=n/$WPA2=y/g" os/linux/config.mk
    sudo make && sudo make install && sudo make clean
    cd ..
    
  4. Blacklist the built-in driver, and load the new one with:

    echo "blacklist rt2800pci" | sudo tee /etc/modprobe.d/blacklist-rt2800pci.conf
    sudo modprobe -rfv rt2800pci
    sudo modprobe -v rt3562sta
    
  5. Your RT3060 should now be functional. You can now open up the Downloads folder in the File Manager and delete the downloaded Ralink file/folder:

    enter image description here

share|improve this answer
1  
You need to change the line "WPA2=HAS_NATIVE_WPA_SUPPLICANT" to "WPA2=HAS_NATIVE_WPA_SUPPLICANT_SUPPORT" or else it won't work!!! –  Jay Oct 3 '12 at 17:43

One solution may be to upgrade to Ubuntu 12.04.

My ralink wireless adapter works out of the box in Ubuntu 12.04, which has an RT3062 chipset.

Although not released yet at the time of writing, Ubuntu 12.04 Beta 2 has proven itself quite stable in my experience, and certainly less of a hassle than having to install the patched driver every time there's a kernel update.

share|improve this answer
    
used to work for me in Ubuntu 12.04, but not anymore... –  georgebrindeiro Jan 22 '13 at 12:51

protected by Community Oct 12 '12 at 12:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.