Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

As it is the only way to activate transparent themes in Gnome-shell:

  • How to disable Nautilus from handling the desktop?
  • Can I make it handle the desktop again?
  • What will happen to the unity and desktop icons?
  • How to handle the desktop icons without nautilus?
share|improve this question

marked as duplicate by Charles Green, muru, Elder Geek, mikewhatever, Eric Carvalho Nov 29 at 16:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3  
use gnome-tweak-tool ... it's like the first option in the interface (to disable this specific thing) –  user258097 Mar 14 at 5:44

4 Answers 4

up vote 7 down vote accepted

You should remove the file /etc/xdg/autostart/nautilus-autostart.desktop (or at least modify the OnlyShowIn line into it).

Then you should always run nautilus with the --no-desktop option (this could also require to modify some menu item or quicklist).

You can manage the desktop with nautilus again at any time launching nautilus without the option --no-desktop.

To manage the desktop in an alternative way you could look at some other file manager.

share|improve this answer
    
Works well.But i was shocked when opening Unity-DE that desktop icons still there, i was thinking that disable nautilus from handling the desktop will happen to all DE-s(i,e, nautilus still handling the desktop in unity and not handling the desktop in Gnome-shell and it is great) –  Naruto Dec 3 '11 at 20:19

I think the best answer for any case is:

gsettings set org.gnome.desktop.background show-desktop-icons false

Copied from @jon-wood because I can't comment, but sure the best answer is from him.

share|improve this answer

I found that running gsettings set org.gnome.desktop.background show-desktop-icons false instantly disabled the desktop icons.

share|improve this answer

If you install the gnome tweak tool (which you'll want anyway) you can disable file manager handling the desktop. But as far as I know you will then have no desktop icons. Most if not all DEs are structured such that the file manager handles desktop icons.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.