Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A couple of times a day, I'll be typing something and realise I can't type spaces. Usually the cursor will flicker instead when I press the spacebar, and I can type all other letters as far as I can tell. If I'm in a terminal the cursor turns from a solid square to an empty square until I release the spacebar.

For some reason, restarting compiz with alt-F2 compiz fixes it, until it next occurs.

I can still copy and paste spaces from sources that already have them, and I can still insert spaces with ctrl-shift-u, 20, enter.

This has been happening for a while, since before I upgraded to maverick, but it feels like its beceoming more frequent. There really doesn't seem to be any kind of a pattern to it.

I'm using 64 bit ubuntu 10.10 on a system76 panp7 laptop.

Any ideas how I might troubleshoot?

EDIT:

using xev, normally a spacebar registers as:

KeyPress event, serial 36, synthetic NO, window 0x5600001,
    root 0x101, subw 0x0, time 26488647, (88,403), root:(748,458),
    state 0x10, keycode 65 (keysym 0x20, space), same_screen YES,
    XLookupString gives 1 bytes: (20) " "
    XmbLookupString gives 1 bytes: (20) " "
    XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0x5600001,
    root 0x101, subw 0x0, time 26488729, (88,403), root:(748,458),
    state 0x10, keycode 65 (keysym 0x20, space), same_screen YES,
    XLookupString gives 1 bytes: (20) " "
    XFilterEvent returns: False

But when it's stopped behaving a press of the spacebar instead gives the three events:

FocusOut event, serial 36, synthetic NO, window 0x5600001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 36, synthetic NO, window 0x5600001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 36, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0 

FURTHER EDIT:

Ok, so I think I've solved the problem, and by that I mean I now know which package to file a bug against.

I have a hot corner which initiates a window picker, and I've customised the window picking so that left click goes to a window, right click closes one and spacebar zooms in on one. When I go to this hot corner, compiz must take control of my spacebar, and clearly isn't giving it back when I leave the window picker.

So I'll be filing a bug against compiz.

reported:here

share|improve this question
    
I have similar issue [1] with my lower-case "V" key in Ubuntu 10.4 on my Acer notebook. Would be happy to see the explanation of the root-cause. I've checked all the configs I've managed to find - nothing suspicious. [1] superuser.com/questions/196832/… –  Serge Broslavsky Oct 20 '10 at 14:19
1  
So I found what was causing it for me, see my edit above. Did you happen to map 'v' to something in the window picker, or any other compiz feature that temporarily gives it a keybinding? –  Chris Billington Oct 21 '10 at 1:03
    
Thank you, Chris. It was a Initiate Viewport Switching mapping. My bad I didn't notice it for the first time I was going through all the Compiz settings. Thank you! :) –  Serge Broslavsky Oct 21 '10 at 5:01

2 Answers 2

up vote 3 down vote accepted

The NotifyGrab is the give-away clue. The only time I've seen that is when the window manager has a global binding which supersedes the window itself.

You can see this clearly if you start xev and go inside the window and press PrtScn where the window manager has arranged to handle PrtScn. In order to do this, the X event model has to FocusOut of the current window with a NotifyGrab event so that the manager can act on the input.

Now as to what is getting your spacebar or v key bound to a window manager action, that's a different - and harder - question.

share|improve this answer
    
Thank you for these hints. I'll try to look at WMs configs. Any hints about what to search for? –  Serge Broslavsky Oct 20 '10 at 18:36
    
Thanks to you both. I'll keep investigating and will edit my question with any new information I find. –  Chris Billington Oct 20 '10 at 23:46

I have the same issue, but with my lower-case Q. Ubuntu 10.04 x-org-edgers... The problem is Compiz, I've dissable it and my q key works again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.