Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Synaptic touchpads used to support a three finger tap for middle clicking in Ubuntu 10.10 (same as clicking the scroll wheel on a mouse.)

This critical functionality is broken in Ubuntu 11.10

How can I restore middle clicking on a touchpad?

share|improve this question
Odd, I never had this functionality with my two Synaptic touchpads... – James Dec 3 '11 at 23:26
Duplicate of… – AlikElzin-kilaka Feb 22 '12 at 7:23
See and vote for the bug: – AlikElzin-kilaka Feb 22 '12 at 7:54
The problem still exists in 14.04 but seemingly not on all devices. I still have this on Lenovo Yoga 2 Pro. The bug url changed: bug 754000 which was moved to… – rubo77 Sep 1 '14 at 6:25

Just found an amazing thing: Taping on the top right corner of the touchpad is like clicking the middle mouse button. I know it's not the same as the triple click and position accuracy is needed :( but it's the closest I could find to triple click.

BTW, clicking on the lower right corner is like clicking the the right mouse button.


share|improve this answer

The problem is with the ubuntu patches against xserver-xorg-input-synaptics package.

The solution to the problem is simple - just replace the ubuntu-provided package with one without those patches.

Here's how:

Download the appropriate Debian package from this site (choose your architecture, either i386 or amd64):

Then remove the original package from your system and replace it with the one downloaded. Reboot the system and 3-finger tapping should be working again.

share|improve this answer
Has anyone tried this? The person answering the question has too little score to take the risk. – AlikElzin-kilaka Feb 22 '12 at 7:15
Whatever "too little score to take the risk" is supposed to mean, I edited the post to add the correct package link. And yes, it works. – Alexandre Apr 12 '12 at 16:17

You could use a commandline programme called "synclient", which should be already on your system.

synclient Tapbutton3=2

where "Tapbutton3" means a Two-Finger Tap, and the 2 is for middle click.

This method only works until restart (or some other mousesettings-program overrides it). To get this functionality permanently, put this in /usr/share/X11/xorg.conf.d/50-synaptics.conf before "EndSection"

Option "TapButton3" "2"
share|improve this answer
Commandline works fine, but only till log out, as you say. But editing 50-synaptics.conf doesn't anything. Shell it on 12.04? The Option "Ignore" should be "on" then? Is it important: spaces, tabs, little/great letters? – user60385 May 4 '12 at 14:44
try adding Option "SHMConfig" "on" after the 'ignore' option and restart – marto May 4 '12 at 19:55
Fixed a typo -- should read "TapButton". However, I just tried changing some settings on my new 12.04 xubuntu install -> 50-synaptics does nothing :( – marto May 4 '12 at 23:15
@marto At the top of 50-synaptics.conf there is a note saying not to edit it- copy it into /etc/X11/xorg.conf.d (you'll probably have to make the directory yourself). Once you do this, edit the copied file. – Istvan Chung Oct 18 '12 at 22:22
Can you help me how to Simulate a middle-click on Lenovo Yoga 2 Pro Synaptics touchpad too? – rubo77 Jun 20 '14 at 10:10

protected by Community May 4 '12 at 15:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.