Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few weeks ago I installed a 32 bit .deb file through the 'force architecture' command (on my 64bit notebook), however the procedure was unsuccessful and I used the apt-get purgecommand to uninstall the app. It seems there are some leftovers of the app I uninstalled which has now broken system update. Synaptic recommended a sudo apt-get install -fwhich I did in the terminal with this initial response:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  libntfs10
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  crossplatformui
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?

I chose 'Y' then got this response:

(Reading database ... 187616 files and directories currently installed.)
Removing crossplatformui ...
ztemtvcdromd: no process found
dpkg: error processing crossplatformui (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 crossplatformui
E: Sub-process /usr/bin/dpkg returned an error code (1)

It seems the app I installed crossplatformuiis still on my system and has caused update manager to stop running with a partial upgrade warning. What do I do now?

share|improve this question
    
now I can't install anything as Software center and terminal both report that the package 'crossplatformui' needs to be uninstalled first Please help –  Mysterio Dec 2 '11 at 23:06
    
There is a similar question on launchpad located:answers.launchpad.net/ubuntu/+source/apt/+question/122715 Can you see if step #6 helps if your comfortable with trying it. –  itnet7 Dec 2 '11 at 23:22
    
Seems he had to reinstall Ubuntu as he wasn't able to solve the issue –  Mysterio Dec 3 '11 at 0:47
    
Had you tried remove it? sudo apt-get remove crossplatformui –  Andre Gil Dec 3 '11 at 4:20

4 Answers 4

up vote 2 down vote accepted

I solved the problem. I had same problem as you had. So what I did:

1- Go to Synaptic Package Manager and Remove [CrossPlatformUI] and all it's dependencies. + May be there still some package will be remain. No problem.

2- As is mentioned above, Run:

gksudo gedit /var/lib/dpkg/status

in terminal.

3- Search in the search area [Package: crossplatformui] You will find four or five line address. I forgot those lines and I can not find them because they are removed. But, any way; follow every line address to find those files.

4- When you find exact files, Right Click on that and choose open as administrator. When file is open, Remove the content of those and save it.

5- Do it for all files. Now go back to Synaptic Package Manager, and mark those package which are remain as completely remove. Synaptic Package Manager will remove those.

6- finally go to terminal again and run again:

gksudo gedit /var/lib/dpkg/status

7- Search for [Package: crossplatformui] again and delete all the informations.

8- You are done. You can check in terminal by running:

sudo apt-get remove CrossPlatformUI

9- As soon as you connect to Internet, run:

sudo apt-get update 

If you were right, there must be no error.

I hope this can help you, and sorry if I have forgot something. I am new to Linux. Good luck.

share|improve this answer
    
Is it necessary to do steps 3,4,5? Can we not directly remove the content from section from the status file? –  alok Aug 21 '13 at 5:08

Maybe we can bypass dpkg like this. First backup your original file:

sudo cp /var/lib/dpkg/status /var/lib/dpkg/status.orig

After that open it to edit:

gksudo gedit /var/lib/dpkg/status

Search for a block something like that:

Package: crossplatformui

..

..

Package: another_package_name

Here, you will delete only crossplatformui block. This means starting with Package: crossplatformui and till the other package block. After deleting the blocak try to remove it again:

sudo dpkg -r crossplatformui

share|improve this answer

Well the only solution here is a complete re-install. Forcing that package to install messed up the system files beyond recovery

share|improve this answer

Have you tried dpkg -P crossplatformui:architecture ?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.