Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.10 using gnome 3 shell. I have set my pc to automatically log into gnome shell so I do not see the login screen. Today I installed some updates and now the gnome panel is gone. When my pc logs in I ONLY see the background. There are no menus, nothing! Even the exit, minimize and maximise buttons in the top tight corner of the windows are gone. Also, alt+f2 also does not work. Any ideas how to fix this?

I have a Nvidia Geforce 7900GTO with the Nvidia proprietary drivers installed. I have also used the recovery mode and removed some packages that apparently were broken. Still does not work.

share|improve this question
    
can you open a terminal with ctrl+alt+t ? if yes, type gnome-shell --replace –  severin Dec 2 '11 at 19:08
    
No, nothing happens when I press ctr+alt+t –  Hannes Dec 2 '11 at 20:26
    
log out, and choose gnome classic (or ubuntu, doesn't really matter), then run gnome-tweak-tool and disable all extensions. Then, log out again, and you should be able to run gnome-shell again. –  severin Dec 2 '11 at 20:40
    
I cannot log out because I cannot open the terminal nor can I see the panel with the logout option. Thats exactly the problem I have. If only I could log out but I see only the wallpaper –  Hannes Dec 2 '11 at 21:02
2  
open a virtual console (ctrl+alt+f1).cd .local/share/gnome-shell/extensions/ and delete the newly installed extensions. (rm -rf "name of extension directory"). then restart lightdm: sudo stop lightdm and sudo start lightdm –  severin Dec 2 '11 at 21:13
show 1 more comment

3 Answers 3

I had the same issue on a Lenovo W530 Laptop and fixed the issue using the following command

sudo apt-get remove nvidia-current.

But this can only be a temporary solution.

share|improve this answer
add comment

I think it's because the updates included cairo-dock to be installed.

If your system (graphic card) opengGL didn't run properly, it might crash gnome shell.

Try to uninstalled it.

share|improve this answer
1  
I use ubuntu in virtual box. Uninstalled cairo-dock fixed the problem. –  Suwandi Halim Dec 13 '12 at 15:44
add comment

I had this problem as well, with Unity. (or any other desktop)

you can access a terminal after login by pressing ctrl+alt+F1 -- on a macbook pro keyboard you have to hold down fn for the F keys to work.

I've removed the nvidia drivers, settings and unity -- after which I was dropped into gnome shell, which worked fine, I assume if I re-install Unity it will be fine as well? I'm not sure as to the cause of this, except that the last thing I did was install the latest (possibly experimental) Nvidia drivers.

I ran these commands:

sudo apt-get remove nvidia-current
sudo apt-get remove nvidia-settings

I also removed (disabled) the /etc/X11/xorg.conf file and removed the ~.Xauthority file.

I can't tell which combination or specific item here was the right thing to do, maybe I overkilled it, if anyone more knowledgeable would like to chime in?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.