Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since updating to ubuntu 11.10 I've had trouble with banshee. In particular when I run it I find that it crashes within an hour without fail. I get the following

     Unhandled Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.NullReferenceException: Object reference not set to an instance of an object
     at Mono.Zeroconf.Providers.AvahiDBus.BrowseService.DisposeResolver () [0x00000] in <filename unknown>:0 
     at Mono.Zeroconf.Providers.AvahiDBus.BrowseService.Dispose () [0x00000] in <filename unknown>:0 
     at Mono.Zeroconf.Providers.AvahiDBus.ServiceBrowser.OnItemRemove (Int32 interface, Protocol protocol, System.String name, System.String type, System.String domain, LookupResultFlags flags) [0x00000] in <filename unknown>:0 
     at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
     at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
    --- End of inner exception stack trace ---
    at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
    at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <filename unknown>:0 
    at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0 
    at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0 
    at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <filename unknown>:0 
    at NDesk.DBus.Connection.HandleSignal (NDesk.DBus.Message msg) [0x00000] in <filename unknown>:0 
    at NDesk.DBus.Connection.DispatchSignals () [0x00000] in <filename unknown>:0 
    at NDesk.DBus.Connection.Iterate () [0x00000] in <filename unknown>:0 
    at Mono.Zeroconf.Providers.AvahiDBus.DBusManager.IterateThread (System.Object o) [0x00000] in <filename unknown>:0

Does anyone else also have this problem?

share|improve this question
    
Have you tried deleting your banshee profile?(in ~/.config/) Have you tried purging and then installing it again? Have you tried using banshee ppa, for daily updates? (in launchpad.net/banshee) Another way of solving this might be: checking the modules, where the problems occurs. It looks like the main problem is within mono, so checking packages such as mono-zeroconf (reinstalling, updating) There's a lot of ways of solving this problem and I don't think it necessarily need a patch –  Paulius Šukys Dec 2 '11 at 12:15
    
If all fails consider using another app while waiting for a fix! –  Stefano Mtangoo Dec 2 '11 at 13:24

1 Answer 1

Remove ~/.cache/banshee*:

rm -rf ~/.cache/banshee*

And run Banshee again. It should not crash now.

share|improve this answer
    
+1 ... and this really does work! –  fossfreedom Apr 1 '12 at 10:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.