Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just updated to 11.10 and GIMP is not working anymore. Here is the error:

    (gimp:1689): GLib-WARNING **: /build/buildd/glib2.0-2.30.0/./glib/goption.c:2168:  
ignoring no-arg, optional-arg or filename flags (8) on option of type 0

Any idea how to solve the problem ?

share|improve this question
    
That's not an error, but a warning. SO it shouldn't stop GIMP from running. Start GIMP and give us the output of px aux, please. Because I think it's running, but the window just doesn't show up. –  RobinJ Dec 2 '11 at 12:50

1 Answer 1

You'll possibly find that you have another instance of GIMP already open with a file sufficiently large that you've put the process to sleep.

At least that's what I encountered.

  1. Launched gimp
  2. Received warning as above.
  3. Ran ps, discovered a sleeping gimp
  4. Killed sleeping gimp
  5. Relaunched gimp, warning reappears, but so does gimp as it should.

lev@isocracy:~/Desktop/webdev$ gimp (gimp:25974): GLib-WARNING **: /build/buildd/glib2.0-2.30.0/./glib/goption.c:2168: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

lev@isocracy:~/Desktop/webdev$ ps afux | grep gimp lev 21142 0.0 1.5 164356 32372 ? Sl Dec05 0:26 gimp-2.6 /home/lev/Desktop/newwebsitevpac.svg lev 25976 0.0 0.0 4188 776 pts/2 S+ 15:08 0:00 _ grep gimp

lev@isocracy:~/Desktop/webdev$ kill 21142

lev@isocracy:~/Desktop/webdev$ gimp & [1] 25982

lev@isocracy:~/Desktop/webdev$ (gimp:25982): GLib-WARNING **: /build/buildd/glib2.0-2.30.0/./glib/goption.c:2168: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.