Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the following error during boot up. But this error doesn't get written to boot.log, as it happens in early boot stages.

mount: mounts none on /dev/pts failed: Device or resource busy

I found this code in /etc/init.d/umountfs file (there is an entry for /dev/pts in it)

 PROTECTED_MOUNTS="$(sed -n '0,/^\/[^ ]* \/ /p' /proc/mounts)"
        WEAK_MTPTS="" # be gentle, don't use force
        REG_MTPTS=""
        TMPFS_MTPTS=""
        while read -r DEV MTPT FSTYPE REST
        do
                echo "$PROTECTED_MOUNTS" | grep -qs "^$DEV $MTPT " && continue
                case "$MTPT" in
                  /|/proc|/dev|/.dev|/dev/pts|/dev/shm|/dev/.static/dev|/proc/*$
                        continue
                        ;;
                  /var/run)
                        continue
                        ;;
                  /var/lock)
                        continue

The file /etc/init.d/umountnfs.sh also has a similar entry. So if I remove the entry /dev/pts will it solve my issue (the mount error getting displayed at boot up).

Here are the contents of mtab file:

/dev/sda1 / ext4 rw,errors=remount-ro,commit=600 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
rpc_pipefs /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
/dev/sda6 /media/windisk fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/blandman/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=blandman 0 0
share|improve this question
    
Does the system boot? Is this an upgrade or a clean 10.10 install? –  Jonathon Oct 24 '10 at 1:07
    
Yes the system boots. It is an upgrade from 10.04. –  nixnotwin Oct 24 '10 at 1:12
    
If your system works, I wouldn't edit any of those files (“if it ain't broke, don't fix it”). At least until you know what causes it. –  JanC Oct 25 '10 at 0:07
    
Can you please post the output of 'cat /etc/mtab' to check mountall... –  Nicolas Schirrer Oct 25 '10 at 8:01
    
This has nothing to do with those umount scripts, so don't edit them. What is your /etc/fstab ? I reckon there's a stray entry in there. –  Jonathon Oct 25 '10 at 15:47
show 2 more comments

3 Answers

up vote 3 down vote accepted
+25

The mountall program that runs during early boot will mount everything listed in /lib/init/fstab and /etc/fstab. Check if there are any duplicate entries for /dev/pts, and if that doesn't turn anything up, check all the init scripts for mention of it:

grep /dev/pts /etc/init/* /etc/init.d/*
share|improve this answer
    
lib/init/fstab has an entry for /dev/pts and /etc/fstab doesn't. And there are no duplicate entries for /dev/pts and the grep command above shows the entries in umountfs and umountnfs.sh like the one I posted in my question. –  nixnotwin Oct 28 '10 at 6:02
add comment

Do you have the same message if you try to mount it manually :

sudo mount -t devpts -o gid=5,mode=620 devpts /dev/pts
share|improve this answer
    
i tried your command: Here is the output mount: devpts already mounted or /dev/pts busy mount: according to mtab, none is already mounted on /dev/pts –  nixnotwin Oct 26 '10 at 6:10
    
The output of your command makee me feel that if we change run level for /dev/pts (makeing it execute little late) in the mtab file it might get solved. How to change run level for mounts? –  nixnotwin Oct 27 '10 at 1:49
add comment

i feel that the best thing to do is leave the files alone as your system still boots. if it annoys you that much maybe its worth re installing (backing up before of course). If you are using wubi it might be a good idea looking at the problems listed on their website. https://wiki.ubuntu.com/WubiGuide#Wubi

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.