Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu 11.10 on my old desktop Dell Dimension 3000. The installation went well except that I noticed that it installed the OS on the 1T external USB disk. The problem I am seeing is that after some no-activity time, it goes into the sleep mode and any key or the power button can wake it up. This does not happen every time. Other times, it will show the lockout menu and request the password.

Does anyone have had similar problem and solved it? Any help will be greatly appreciated. I followed some similar posts and disabled my "hibernate" and "suspend" option on the menu.

The only way I can come out of it is to power cycle the computer.

share|improve this question
    
This is likely an issue with the video driver, which is the most error prone to sleep issues. which graphics "card" do you use? –  user606723 Dec 2 '11 at 16:04
    
It uses INtel 82865 Graphics controller. –  Raj Dec 3 '11 at 23:32
add comment

2 Answers 2

Edit/Create xorg.conf file

sudo gedit /etc/X11/xorg.conf

And paste these lines:

Section "ServerFlags"
Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
Option "DontZap" "false"
EndSection

Reboot. Done.

share|improve this answer
    
Thanks man. This also worked on Ubuntu 11.10 running on Dell XPS 16. –  Maher4Ever Dec 20 '11 at 11:27
1  
Thanks for your help but could you please explain what it does ? Does is totally suppress sleeping ? It is nice to give solution but if one explains just a little what these line do we can learn from it, not just blindly solve a problem. This is a very big problem everywhere on the web. We need to count on people to give us ready-to-use answers but we never learn anything. I don't understand how someone can be satisfied by an answer he does not understand. –  user44450 Jan 31 '12 at 22:52
add comment

I would try to install the "Other Devices/Hardware" control panel , run it , and then switch the video driver (if possible). Also, try using your Linux live cd to run a memtest on the ram.

share|improve this answer
    
You don't need to boot from the live CD to check the RAM, unless a serious hard disk problem is also suspected. You can run memtest86+ (the RAM checking utility) from the hard disk by selecting it from the GRUB2 menu at boot-time. (Hold down Shift while booting to ensure you see this menu.) –  Eliah Kagan Dec 2 '11 at 0:15
    
Thanks for the quick reply. What is "Other Devices/Hardware" control panel? Where do I install this from? –  Raj Dec 2 '11 at 0:15
    
RAM checking facility runs clean. Yet I am having the same problem. Any more suggestions? –  Raj Dec 2 '11 at 20:34
    
For those who are looking for a solution ( I tried and it works) is at askubuntu.com/questions/73117/… –  Raj Dec 4 '11 at 12:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.