Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have written a filesystem over Fuse to access a remote pseudo-NAS (the French "Freebox V6", I'll soon publish it as GPL3... when it's a little bit more polished!).

The NAS is connected to a home ADSL, thus data comes down at the upload speed of ADSL, which is at best 1Mbps.

My mount works fine (read-only at the moment), but Nautilus sees the mountpoint (and all sub-directories) as a "local" filesystem and tries to make thumbnails.

As I have a directory full of images, this is quite horrible, because Nautilus then opens ALL the images to try to display the thumbnail.

I could switch the Nautilus preferences to "Never" for thumbnails, but then I'll loose thumbnails on my "real" local filesystem.

So the question is: with the preference "Only for local filesystem", how can I instruct Nautilus that my mountpoint is in fact NOT a local mount so that it will stop trying to draw thumbnails on that specific mount, but continue "thumbnailing" on mounts that are really local?

Edit note: the same things happens if you use "standard worldwide" mounts such as sshfs, davfs,... as long as you mount over a relatively slow network (ADSL) and have images/movies on your mounted tree.

share|improve this question
    
Source code and binary (Lucid 64) for this filesystem [Beta] is now published : (forum.ubuntu-fr.org/viewtopic.php?id=744561) –  Zakhar Dec 3 '11 at 0:30
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Mar 10 '12 at 16:48
    
You are right, as the question was initially worded. But in fact, as the anwser bellow proves, it affects ALL types of "network-mount", and not only my own development: sshfs, davfs,... As long a you mount these sort of mount over a slow network, the issue happens. ... and how do I "unflag"... (searching)... –  Zakhar Jun 17 '12 at 8:29

1 Answer 1

I suspect this isn't currently possible - I've been searching for solutions with sshfs based mounts and been unable to find any.

share|improve this answer
1  
Thanks for your answer, I have the same issue with davfs2 (and I assume we will have the same sort of issue with all "network" mounts). I think I should "launchpad" a suggestion as there are more and more "cloud" storage and this issue is going to be more and more pregnant in the future! –  Zakhar Jun 17 '12 at 8:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.