Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I attempted to take a screenshot by hitting print screen. Unfortunately, this was the result:

Empty Desktop

Didn't show the open Firefox, Chrome or terminal windows. It also didn't show the top bar or any desktop icons. Just the desktop background. I tried running the Screenshot app directly and obtained the same result. Shutter worked though. I am using 11.10 with the Gnome 3.2.1 shell. Does anyone know what the issue is?

My system settings are:

Driver: VESA: RV710 Experience: Standard

share|improve this question
1  
mmm, very strange but have you tried Shutter it is the best program to take a screen-shot(found in Ubuntu repository) –  Naruto Dec 1 '11 at 23:18
    
I am not able to reproduce this issue. Can you provide more information on your setup? You may have a bug here. –  WarriorIng64 Dec 2 '11 at 1:55
    
@WarriorIng64: What kind of info? –  Casebash Dec 2 '11 at 2:12
1  
@Casebash For starters, you could tell us what your hardware setup is (particularly graphics) and how you installed GNOME Shell (if you're not using the Software Center's version in 11.10). –  WarriorIng64 Dec 2 '11 at 2:15
1  
Repeat your test, but use Screenshot app. directly. This will reduce issue (to resolve) to a keyboard triggered event vs. the 'Screenshot' app. itself. –  david6 Dec 2 '11 at 4:11
show 7 more comments

closed as too localized by jrg, jokerdino, Marco Ceppi Jan 25 '12 at 22:18

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Try changing the default time to at least one second in the screenshot options, like the example below. I had the same issue and this workaround solved it. I still get an instant screenshot when pressing PrtScn , but the other two options have a one-second delay.

Screenshot options dialog

share|improve this answer
    
I tried delays of up to 4 seconds, but they didn't actually work. There is a flashing animation before the screenshot which might be the cause of this error –  Casebash Dec 7 '11 at 3:12
    
That's too bad, I guess your best bet is to follow @Naruto's advice and use Shutter until this bug gets sorted out. –  Tom Brossman Dec 7 '11 at 8:51
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.