Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I change the default session for when using auto-logins?

I've installed the Lubuntu desktop on my Ubuntu 11.10 PC. My PC logs straight in to Ubuntu Unity without asking for a password. How do I make my PC boot in to Lubuntu as default instead of Unity.

share|improve this question
    
If use lubuntu in your last session it should enter to lubuntu if you log back in or reboot your pc –  Engels Peralta Dec 1 '11 at 22:34
    
@BrunoPereira - have added Lubuntu and LXDE to the duplicate. –  fossfreedom Dec 1 '11 at 23:03
    
I think this is not really a duplicate of that question since, when installing lubuntu-desktop on a standard Ubuntu Oneiric system, the user is given the choice between sticking with lightdm or switching to lxdm. That question is specifically and explicitly about lightdm. –  Eliah Kagan Dec 2 '11 at 0:21
    
@fossfreedom good job! –  Bruno Pereira Dec 2 '11 at 7:27
add comment

marked as duplicate by fossfreedom, Bruno Pereira, Jorge Castro, Uri Herrera, Marco Ceppi Dec 2 '11 at 3:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

A regular Ubuntu 11.10 system uses LightDM as its display manager, by default. A Lubuntu 11.10 system uses LXDM as its default display manager. When you install lubuntu-desktop on a regular Ubuntu 11.10 system, you may be prompted to select what display manager you wish to use. You can select between LightDM, LXDM, or other display managers if they are installed, including GDM (which was the default display manager for regular Ubuntu systems prior to version 11.10).

No matter which display manager you are using, you can change the default session type for your user by logging out (click the power/configuration icon at the upper-right corner of the screen and select Log Out). Logging out brings you to the login screen, even on systems where you are automatically logged in on boot. Then you can select whatever session type you want (in this case, you'd want to select Lubuntu), and log in. Your session type will be remembered (for that user account).

Different display managers put the drop-down menu used to select between session types in different places. If you have trouble finding it even after trying, you can comment or edit your question describing what the menu looks like (including its color), which will help to determine what display manager is enabled, which will make it possible to provide a detailed description of how to select your session type. But you may very well find that selecting your session type is quite easy.

If you select your session type and log in but you're still automatically logged in with the wrong session type, then you can disable automatic login, log out, log back in (selecting the session type you want), and re-enable automatic login. (If you don't know how to do this and searching doesn't help, please post a comment and I'll add that information to this post.)

If that doesn't work either, and LightDM is your display manager, see this related question. Please note that changing the global default session type will only work if it is not overridden by a user-specific preference. So if you're being logged in to a Unity session because that's the global default and there is no user-specific default, then the accepted answer there will help. But if you're being logged in to a Unity session because that's set as your user-specific session type, then you may want to manually change the user-specific default to Lubuntu (or, less likely, LXDE) using the directions in this answer.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.